none
Disable the reverse proxy feature on UAG RRS feed

  • Question

  • We have a SharePoint web app that runs a remote desktop session to a server on the same domain as the SP box.

    Users log on to UAG and it points them directly to the SharePoint site.  When the click on the RDP, it says it can't find the RDP box.

    If I run the same session from the UAG Portal page it works fine.

    I think it is a routing problem.  It works fine through a TMG box so I think it might be something to do with the reverse proxy settings.

    Any idea if I can disable this on UAG.

    Thursday, April 4, 2013 12:45 PM

All replies

  • Hi Amig@. I understand from your words that you are publishing through UAG a SharePoint web application. The publication works fine but as part of this application there is a RDP connection to a server and this doesn't work. Well, you have to notice that a web application and a RDP session are different applications. The first one is published by UAG using reverse proxy technics but the second one must be treated differently as it is a client/server application. UAG has a template for handling client/server applications (some client components have to be downloaded to the endpoint). Also, UAG has a template named "browser embedded applications" that can be helpful. This templates is used for applications where the first connection is to a web site and following that there is a client/server application launched (think about IBM host on demand, or Citrix). However, as your first application is SharePoint and SharePoint has an specific template for it I would try this:

    Add a TS Client tunneling in your trunk (it is located under the category Terminal Service/RDP Services. Define the RDS server and mark in the Client Settings tab "Basic" for the Socket Forwarder mode. In the Portal Link tan remove the mark that says "add portal and toolbar link".

    Then, in the General tab of the SharePoint publishing, choose the newly created TS application as a Prerequisite application

    Activate the configuration and try again

    Hope it helps


    // Raúl - I love this game

    Monday, April 8, 2013 7:55 AM