none
Windows Server 2008 R2 DNS Issues RRS feed

  • Question

  • Hello all!

    So let me explain what I have then I will explain what the issue is. 

    I have a central server running Windows Server 2008 R2.

    All Computers that are connected are running Windows 7 SP1.

    It manages our domain as well as the connection to the internet and our DNS using xxxx.local prefix for the connection. I have 8 computers on this network. All have forced assigned IP address.

    The issue is that I have two computers that will connect to the internal network but wont connect to the outside internet aka it won't connect to www.google.com

    When I run trouble shooter I get DNS errors saying that the computer cant connect to the DNS server.

    I went into DNS management and I see that it has been set up and all the computers show up on it. However, when I go to the Reverse lookup section it only shows ips that look like the follow 192.168.200.xxx  The computers that connect to the network all have the ip as follows 192.168.100.xxx .

    I did create a Reverse Look up zone for 192.168.100.xxx and added a record to that for my computers but it still doesn't seem to resolve the issue.

    What am I missing here?

    Any help would be great and I can clarify if needed. 

    Thanks again!

    Wednesday, January 18, 2017 7:03 PM

All replies

  • Hi,

    Are you using a single domain controller and DHCP roles are also installed on same server?

    First you need to check the IP Address of your Dc and same IP, you need to also enter on your Dc Preferred DNS.

    Now go to DNS manager and Create a Reverse look up Zone and check your Root Hints /Forwarder what you have configure to resolve external query. If require then in Forwarder tab add your Service provider DNS IP/any Global DNS IP. 

    Run the nslookup to check that DNS resolving your query. 

    Also check the status of IPconfig /all on Client.

    Wednesday, January 18, 2017 7:56 PM
  • Thank you for the quick response. 

    To answer your first question yes. DHCP and DC are on the same server.

    The Address of my DC are the same IP as well as DNS is the same IP. 

    So my DNS is xxx.xxx.100.5

    I also show another DNS entry for xxx.xxx.200.5 this is for another location entirely and that server is at another builder 4 miles away. We do own it. 

    nslookup  confirmed that DNS is resolving my query. 

    As for the Reverse look up Zone I did create one resolving for 100.192.168 and there was already one set up for 200.192.168.

    I don't believe I require a Forward and the Root Hints appear to be set up properly 

    But my two computers are still unable to resolve DNS

    EDIT: I would also like to point out that the computers go off line about 830-9 am every day and come back online about 245pm every day. 

    This is a pretty consistent thing 

    • Edited by Keith Pottratz Wednesday, January 18, 2017 9:43 PM updating information
    Wednesday, January 18, 2017 8:07 PM
  • Can you pl. give me output of nslookup? 

    I think you are using 2 DNS server? But your sub net is different. 

    Thursday, January 19, 2017 4:59 AM
  • Here are the results of nslookup:

    >Talonxxxx.local

    Server: poscon.xxxxxx.local

    Address: 192.168.100.5

    xxxxx.local

    primary name server = poscon.xxxx.local

    responsible mail addr = hostmaster

    serial = 11507

    refresh = 900 <15 mins> 

    retry = 600 <10 mins>

    expire = 86400<1 day>

    default TTL = 3600 <1 hour>

    >server 192.168.100.5

    Default Server: poscon.xxxx.local

    Address: 192.168.100.5

    ---------------

    Hope this helps




    Thursday, January 19, 2017 9:38 PM
  • Here is the ipconfig /all for the computer that is having issues resolving DNS:

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\administrator>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : ACCTNG
       Primary Dns Suffix  . . . . . . . : TalonWinery.local
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : TalonWinery.local

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
       Physical Address. . . . . . . . . : 00-21-97-69-B9-F6
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 192.168.100.109(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 192.168.100.254
       DNS Servers . . . . . . . . . . . : 192.168.100.5
                                           192.168.200.100
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{D8880E85-C0A9-440B-B2B8-93D3C2DBECC9}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Local Area Connection* 11:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    C:\Users\administrator>

    Friday, January 20, 2017 7:27 PM
  • Can u please put below DNS manually on Client PC:

    DNS Servers . . . . . . . . . . . : 192.168.100.5

    After that Check the below:

    C:\Windows\system32>nslookup
    Default Server:  dc.corp.AIS.com
    Address:  192.168.5.233

    > google.com
    Server:  dc.corp.AIS.com
    Address:  192.168.5.233

    Non-authoritative answer:
    Name:    google.com
    Addresses:  2404:6800:4007:800::200e
              216.58.197.78

    C:\Windows\system32>ping 192.168.100.5

    C:\Windows\system32>ping google.com

    C:\Windows\system32>ping 8.8.8.8

    Tuesday, January 24, 2017 11:15 AM
  • nslookup

    Default Server: Unkown

    192.168.100.5

    google.com

    Default Server: Unkown

    Address: 192.168.100.5

    non-authoritative answer:

    Name: gogle.com

    Servers: 216.58.217.46

    When pinging 192.168.100.5 all packets are recieved

    When pinging google.com all packets lost

    When pinging 8.8.8.8 all packets lost

    Tuesday, January 24, 2017 7:40 PM
  • Hi,

    As per below output:

    1- nslookup

    Default Server: Unkown

    192.168.100.5

    You need to create the Reverse Lookup Zone: 100.168.192.in - addr.arpa

    Adding a Reverse Lookup Zone

    2-

    google.com

    Default Server: Unkown

    Address: 192.168.100.5

    non-authoritative answer:

    Name: gogle.com

    Servers: 216.58.217.46

    Your DNS is working.

    3-

    When pinging 192.168.100.5 all packets are recieved

    When pinging google.com all packets lost

    When pinging 8.8.8.8 all packets lost

    Can your please send the tracert report of 8.8.8.8

    C:\Users\admin>tracert 8.8.8.8


    Friday, January 27, 2017 5:22 AM
  • For the new Reverse look up zone do I need to create PTR for that zone for all computers or will they auto populate?

    -----------------------------

    Results of tracert:

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\administrator>tracert 8.8.8.8

    Tracing route to google-public-dns-a.google.com [8.8.8.8]
    over a maximum of 30 hops:

      1     *        *        *     Request timed out.
      2    12 ms    12 ms    12 ms  host-69-144-131-253.bzm-mt.client.bresnan.net [6
    9.144.131.253]
      3    12 ms    11 ms    11 ms  host-69-146-239-6.static.bresnan.net [69.146.239
    .6]
      4    11 ms    11 ms    35 ms  gdjco001cr5-xe-5-1-0-u0.int.bresnan.net [72.175.
    110.232]
      5    23 ms    21 ms    22 ms  host-72-175-111-169.bln-mt.client.bresnan.net [7
    2.175.111.169]
      6    22 ms    31 ms    21 ms  host-72-175-110-217.bln-mt.client.bresnan.net [7
    2.175.110.217]
      7    40 ms    22 ms    21 ms  72.175.111.225
      8    24 ms    21 ms    22 ms  216.239.42.247
      9    41 ms    21 ms    22 ms  72.14.233.239
     10    23 ms    31 ms    22 ms  google-public-dns-a.google.com [8.8.8.8]

    Trace complete.

    C:\Users\administrator>


    Friday, January 27, 2017 5:57 PM
  • As per knowledge if you are using the DHCP, then PTR will populate automatically during the lease renew otherwise you need to mark the checkbox "Update associated pointer record" on properties of all records. 

    If in Your Environment have DHCP Server then can please enable the DHCP on client then check the Internet.

    Further it may that from your Corporate Firewall on this Client have No internet access. Pl. verify it. 


    Friday, January 27, 2017 6:43 PM
  • Hi,

    Can you please check and confirm if your reported issue has been resolved? 

    Friday, February 3, 2017 9:35 AM
  • Issue doesn't seem to be resolved. 

    It's pretty intermittent and doesn't seem to happy at any particular time now.  Now I have three computers that do it instead of two

    Friday, February 3, 2017 5:55 PM