locked
Application Service depend on the netlogon not start automatically in Windows 7 but start in Windows XP RRS feed

  • Question

  • I am using the Chromeleon application in my Windows 7 Professsional 64 bit PC. When my analyst restart the PC then the chromelon application services depend on the AD account failed to start due to logon failure. I am using the Dell Optiplex 3010 model and i am posting the sequence of event when PC restart.

    Log Name:      System
    Source:        Microsoft-Windows-Kernel-General
    Date:          15/04/14 4:37:21 PM
    Event ID:      12
    Task Category: None
    Level:         Information
    Keywords:     
    User:          SYSTEM
    Computer:      LLMDDES1084.lupinworld.com
    Description:
    The operating system started at system time ‎2014‎-‎04‎-‎15T11:07:21.125599300Z.
    Event Xml:
    < Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
       <System>
        <Provider Name="Microsoft-Windows-Kernel-General" Guid="{A68CA8B7-004F-D7B6-A698-07E2DE0F1F5D}" />
        <EventID>12</EventID>
        <Version>0</Version>
        <Level>4</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8000000000000000</Keywords>
        <TimeCreated SystemTime="2014-04-15T11:07:21.593600200Z" />
        <EventRecordID>19335</EventRecordID>
        <Correlation />
        <Execution ProcessID="4" ThreadID="8" />
        <Channel>System</Channel>
        <Computer>LLMDDES1084.lupinworld.com</Computer>
        <Security UserID="S-1-5-18" />
      </System>
      <EventData>
        <Data Name="MajorVersion">6</Data>
        <Data Name="MinorVersion">1</Data>
        <Data Name="BuildVersion">7601</Data>
        <Data Name="QfeVersion">18229</Data>
        <Data Name="ServiceVersion">1</Data>
        <Data Name="BootMode">0</Data>
        <Data Name="StartTime">2014-04-15T11:07:21.125599300Z</Data>
      </EventData>
    < /Event>

    then problem came

    Log Name:      System
    Source:        RTL8167
    Date:          15/04/14 4:37:33 PM
    Event ID:      1
    Task Category: None
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      LLMDDES1084.lupinworld.com
    Description:
    Realtek PCIe GBE Family Controller is disconnected from network.
    Event Xml:
    < Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
       <System>
        <Provider Name="RTL8167" />
        <EventID Qualifiers="32768">1</EventID>
        <Level>3</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2014-04-15T11:07:33.122020400Z" />
        <EventRecordID>19349</EventRecordID>
        <Channel>System</Channel>
        <Computer>LLMDDES1084.lupinworld.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>\Device\NDMP2</Data>
        <Data>Realtek PCIe GBE Family Controller</Data>
        <Binary>00000000020030000000000001000080000000000000000000000000000000000000000000000000</Binary>
      </EventData>
    < /Event>

    then

    Log Name:      System
    Source:        NETLOGON
    Date:          15/04/14 4:37:41 PM
    Event ID:      5719
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      LLMDDES1084.lupinworld.com
    Description:
    This computer was not able to set up a secure session with a domain controller in domain LUPINWORLD due to the following:
    There are currently no logon servers available to service the logon request.
    This may lead to authentication problems. Make sure that this computer is connected to the network. If the problem persists, please contact your domain administrator. 

    ADDITIONAL INFO
    If this computer is a domain controller for the specified domain, it sets up the secure session to the primary domain controller emulator in the specified domain. Otherwise, this computer sets up the secure session to any domain controller in the specified domain.
    Event Xml:
    < Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
       <System>
        <Provider Name="NETLOGON" />
        <EventID Qualifiers="0">5719</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2014-04-15T11:07:41.000000000Z" />
        <EventRecordID>19372</EventRecordID>
        <Channel>System</Channel>
        <Computer>LLMDDES1084.lupinworld.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>LUPINWORLD</Data>
        <Data>%%1311</Data>
        <Binary>5E0000C0</Binary>
      </EventData>
    < /Event>

    then DHCP also starts

    Log Name:      System
    Source:        Microsoft-Windows-Dhcp-Client
    Date:          15/04/14 4:37:40 PM
    Event ID:      50036
    Task Category: Service State Event
    Level:         Information
    Keywords:     
    User:          LOCAL SERVICE
    Computer:      LLMDDES1084.lupinworld.com
    Description:
    DHCPv4 client service is started
    Event Xml:
    < Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
       <System>
        <Provider Name="Microsoft-Windows-Dhcp-Client" Guid="{15A7A4F8-0072-4EAB-ABAD-F98A4D666AED}" />
        <EventID>50036</EventID>
        <Version>0</Version>
        <Level>4</Level>
        <Task>4</Task>
        <Opcode>68</Opcode>
        <Keywords>0x2000000000000000</Keywords>
        <TimeCreated SystemTime="2014-04-15T11:07:40.818034300Z" />
        <EventRecordID>19375</EventRecordID>
        <Correlation />
        <Execution ProcessID="868" ThreadID="1192" />
        <Channel>System</Channel>
        <Computer>LLMDDES1084.lupinworld.com</Computer>
        <Security UserID="S-1-5-19" />
      </System>
      <EventData>
      </EventData>
    < /Event>

    then Netlogon starts

    Log Name:      System
    Source:        Service Control Manager
    Date:          15/04/14 4:37:41 PM
    Event ID:      7036
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      LLMDDES1084.lupinworld.com
    Description:
    The Netlogon service entered the running state.
    Event Xml:
    < Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
       <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="16384">7036</EventID>
        <Version>0</Version>
        <Level>4</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2014-04-15T11:07:41.218034900Z" />
        <EventRecordID>19384</EventRecordID>
        <Correlation />
        <Execution ProcessID="504" ThreadID="676" />
        <Channel>System</Channel>
        <Computer>LLMDDES1084.lupinworld.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">Netlogon</Data>
        <Data Name="param2">running</Data>
        <Binary>4E00650074006C006F0067006F006E002F0034000000</Binary>
      </EventData>
    < /Event>

    then my chromel service shows error and do not start

    Log Name:      System
    Source:        Service Control Manager
    Date:          15/04/14 4:37:41 PM
    Event ID:      7038
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      LLMDDES1084.lupinworld.com
    Description:
    The CmImpService service was unable to log on as Lupinworld\CMTRANS with the currently configured password due to the following error:
    There are currently no logon servers available to service the logon request.

    To ensure that the service is configured properly, use the Services snap-in in Microsoft Management Console (MMC).
    Event Xml:
    < Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
       <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="49152">7038</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2014-04-15T11:07:41.478035200Z" />
        <EventRecordID>19386</EventRecordID>
        <Correlation />
        <Execution ProcessID="504" ThreadID="508" />
        <Channel>System</Channel>
        <Computer>LLMDDES1084.lupinworld.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">CmImpService</Data>
        <Data Name="param2">Lupinworld\CMTRANS</Data>
        <Data Name="param3">%%1311</Data>
      </EventData>
    < /Event>

    another service

    Log Name:      System
    Source:        Service Control Manager
    Date:          15/04/14 4:37:41 PM
    Event ID:      7038
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      LLMDDES1084.lupinworld.com
    Description:
    The CmServer service was unable to log on as LUPINWORLD\CMTRANS with the currently configured password due to the following error:
    There are currently no logon servers available to service the logon request.

    To ensure that the service is configured properly, use the Services snap-in in Microsoft Management Console (MMC).
    Event Xml:
    < Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event
       <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="49152">7038</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2014-04-15T11:07:41.478035200Z" />
        <EventRecordID>19391</EventRecordID>
        <Correlation />
        <Execution ProcessID="504" ThreadID="508" />
        <Channel>System</Channel>
        <Computer>LLMDDES1084.lupinworld.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">CmServer</Data>
        <Data Name="param2">LUPINWORLD\CMTRANS</Data>
        <Data Name="param3">%%1311</Data>
      </EventData>
    < /Event>

    password of the username CMTRANS never changed. Same application I am using in Windows XP desktops with same desktop model. This logon failure problem never occured in windows XP. even i removed the network cable in XP system and restart then itself all the chromeleon services are found running.

    but in windows 7 I am facing this issue.

    Friday, April 18, 2014 5:55 PM

All replies

  • Hi,

    From the log, it seems that there're two services can not automatically start after you restart the PC, I suggest you logon to a DC, then open mmc, add a Service snap-in for that problematic PC "LLMDDES1084.lupinworld.com", then check and make sure the startup type of the CmServer servivice and CmImpService service are set to "Automatic".

    For Chromeleon application, we're not familiar with this product, but you can contact this support

    http://www.dionex.com/en-us/products/chromatography-software/chromeleon72/lp-73027.html

    NOTE This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.

     


    Yolanda Zhu
    TechNet Community Support

    Monday, April 21, 2014 6:03 AM
  • Total 4 services are for this Chromeleon application. I just mentioned 2 for reference. all 4 services not starting when starting.

    these services startup set to the "Log On As" to one of the Domain account and when PC starts, it takes time to take IP from DHCP and in tern netlogon cannot find the Domain and also chromeleon services also not able to find the Domain to authenticate the service. hence service stopped with error "no logon server available".

    But in XP machine with same software, same network, same DC, same network switch, when PC starts no services found stopped. even if I remove the network cable from XP PC and then restart, services found running even with netlogon error.

    What in XP which even without network service not stopped, but in win 7 a small delay to network connection stopped the service.

    Tuesday, April 22, 2014 6:31 PM
  • From your description, the application can be running even with a netlogon error in XP while not in Windows 7, strange, we're not familiar with this application, have you contacted the vender of this application for some ideas? 

    Yolanda Zhu
    TechNet Community Support

    Thursday, April 24, 2014 9:14 AM
  • Vendor has asked to set the service to delayed start. so after all services these services will start.

    somehow it works but still unanswered that these services not stopped in XP but stopped in Windows 7.

    • Edited by Devershi Saturday, May 31, 2014 5:00 PM
    Saturday, May 31, 2014 4:58 PM