none
Microsoft Azure Recovery Services Agent / OBEngine service will not start RRS feed

  • Question

  • Running single DPM 2012 R2 on Server 2012R2 machine and attempting to get Azure Backups setup.

    I followed all the steps here: https://azure.microsoft.com/en-us/documentation/articles/backup-azure-dpm-introduction/ to setup Azure backups for DPM.

    I downloaded the Microsoft Azure Recovery Services Agent (v2.0.9040.0) and it installed with no errors on DPM machine.

    Then in DPM Admin console under online and click on Register, next (I don't have a proxy server), then I get the error: "The Windows Azure Backup Agent cannot connect the the OBEngine service. (ID: 100052) Verify that the OBEngine service is present in the Services Control Panel and that the port 6049 is available."

    In Services OBRecoveryServicesManagementAgent.exe is running fine but cbengine.exe appears to be the problem.

    If I try to start the service manually I get "The Microsoft Azure Recovery Services Agent service could not be started. A system error has occurred. System error 1067 has occurred. The process terminated unexpectedly."

    Event Viewer info doesn't seem to helpful either:

    Log Name:      System
    Source:        Service Control Manager
    Date:          8/3/2016 8:42:15 AM
    Event ID:      7034
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      DPM.clc.local
    Description:
    The Microsoft Azure Recovery Services Agent service terminated unexpectedly.  It has done this 5 time(s).
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="49152">7034</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x8080000000000000</Keywords>
        <TimeCreated SystemTime="2016-08-03T12:42:15.060760700Z" />
        <EventRecordID>1392776</EventRecordID>
        <Correlation />
        <Execution ProcessID="752" ThreadID="6084" />
        <Channel>System</Channel>
        <Computer>DPM.clc.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">Microsoft Azure Recovery Services Agent</Data>
        <Data Name="param2">5</Data>
        <Binary>6F00620065006E00670069006E0065000000</Binary>
      </EventData>
    </Event>

    Full disclosure, the DPM server was running Server 2008R2 when I tried all this and the install worked but I was busy with another issue and upgraded the server to 2012R2. When I got back to Azure backups I ran into this.

    I've uninstalled and reinstall the Azure backup client and I pretty sure that port 6049 is not the issue.

    Something is stopping the OBEngine from starting.

    Appreciate any ideas!


    • Edited by grf979 Wednesday, August 3, 2016 1:10 PM
    Wednesday, August 3, 2016 1:09 PM