none
Internet Explorer issues with Steady State. RRS feed

  • Question

  • I am planning to use Windows Steady State within my public Library for OPAC stations.  This will allow users to access our online catalogue and nothing else.  To this end I have set up a user with Windows Steady State and have locked it right down to having nothing on the start menu or desktop but the Internet Explorer icon (Shortcuts have all been modified to add the '-K' switch so that IE will open in Kiosk mode also).  I have restricted internet access to a minimal list of web sites so these do not become public internet stations.

    My problem is that any images embedded into the Catalogue pages are not displaying correctly.  We have an icon link on the page for our Library logo which points to our public URL and we use contentcafe to provide us with the images for our books in the catalogue.  None of these will display.  I have added the main URL for these into the list of allowed websites in the Steady State configuration but they just will not display.  is there a setting somewhere that limits embedded links in web pages from displaying?  Anyone else have this issue?
    Tuesday, June 9, 2009 9:48 PM

Answers

  • Thanks for the post Sean, however i did try this to no avail.
    As bizarre as this is going to sound what i did last night worked (sort of).  No, not a desperate dance to the MS gods.  All I did was change the order of allowed websites in my field.  I deleted all that were there, saved the profile, then re-added them and the images showed the next time I logged in.

    Now for the kicker.  From my catalogue I also can allow links over to my public web page.  Since one of the domains that was in my allow list was my public website, and the linked image now displayed you would think I could click on the link and go to my site right?  wrong!  Any links from my catalogue pages which then go out to my public pages don't work at all. I just get the "Page could not be displayed". 

    I'm quickly getting that this restrict IE access is not an exact science with Steady State.  it seems very inconsistent and somewhat limited. 

    We have decided to lock down the session as we have with Steady State and then will restrict the site access through use of a simple Proxy.
    Thursday, June 11, 2009 4:27 PM

All replies

  • Hi, thanks for the post. For the current situation, I consider you should be able to view the images if the setting is correctly configured. I suggest you also try wildcard "*" to set allowed addresses, such as *.site.com/* then let's see if those images can be shown.


    Sean Zhu - MSFT
    Thursday, June 11, 2009 7:43 AM
    Moderator
  • Thanks for the post Sean, however i did try this to no avail.
    As bizarre as this is going to sound what i did last night worked (sort of).  No, not a desperate dance to the MS gods.  All I did was change the order of allowed websites in my field.  I deleted all that were there, saved the profile, then re-added them and the images showed the next time I logged in.

    Now for the kicker.  From my catalogue I also can allow links over to my public web page.  Since one of the domains that was in my allow list was my public website, and the linked image now displayed you would think I could click on the link and go to my site right?  wrong!  Any links from my catalogue pages which then go out to my public pages don't work at all. I just get the "Page could not be displayed". 

    I'm quickly getting that this restrict IE access is not an exact science with Steady State.  it seems very inconsistent and somewhat limited. 

    We have decided to lock down the session as we have with Steady State and then will restrict the site access through use of a simple Proxy.
    Thursday, June 11, 2009 4:27 PM
  • Hi, thanks for the post. For the current situation, I consider you should be able to view the images if the setting is correctly configured. I suggest you also try wildcard "*" to set allowed addresses, such as *.site.com/* then let's see if those images can be shown.


    Sean Zhu - MSFT
    Have you actually tried entering an address (with the wildcards as you suggest) in the format you listed? SteadyState will not accept it. Please test your suggestions before posting or make note of a particular version that allows the entries in the format you used.
    Web Architect
    Tuesday, November 16, 2010 12:31 AM