none
can`t associate reusable workflow to list which was created from template

    Question

  • Hello all,

    I have a terrible problem

    I am using sharepoint online

    I have site, reusable workflow and list

    it work perfect

    than I create template from this list

    and create a lot of new lists on this site from this template, because limit for 5000 items for one list

    all work perfect

    but one time I got email problem from workflow for one list

    and I deleted workflow from this list and try to associate reusable workflow for this list again

    I want to do just refresh, but get problem

    how I can associate reusable workflow again to list which was created from template and has this reusable workflow earlier ?

    thank for all

    of course I can create new list form template, but how I can transfer data from my problem list ?



    • Edited by VictorVP Tuesday, February 21, 2017 9:15 AM
    Monday, February 20, 2017 4:42 PM

Answers

  • Hi,

    I have tested in my SharePoint online. I created a new list with a 2010 reusable workflow and saved it as template. Then I created a new list based on this template and ran the 2010 reusable workflow in this new list. After that I removed the workflow and I’m able to add it again.

    Please try to republish the reusable workflow and access the problematical list > List Settings > Workflow settings, click Add a workflow, check if the reusable workflow is shown in available workflow templates.

    If the reusable workflow still doesn’t show, are the workflow and list in the same site?

    Will the issue occur if you create a new list?

    You can save this list as a template (include content) and create a new list, then test whether this issue occurs.

    Thanks,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by VictorVP Wednesday, March 1, 2017 5:02 PM
    Wednesday, February 22, 2017 7:35 AM
    Moderator
  • Hi,
    Is there any update?
    If my reply is helpful to you, you can mark as answer.
    Thanks,
    Dean Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by VictorVP Wednesday, March 1, 2017 5:02 PM
    Monday, February 27, 2017 1:38 PM
    Moderator

All replies

  • Hi,

    I have tested in my SharePoint online. I created a new list with a 2010 reusable workflow and saved it as template. Then I created a new list based on this template and ran the 2010 reusable workflow in this new list. After that I removed the workflow and I’m able to add it again.

    Please try to republish the reusable workflow and access the problematical list > List Settings > Workflow settings, click Add a workflow, check if the reusable workflow is shown in available workflow templates.

    If the reusable workflow still doesn’t show, are the workflow and list in the same site?

    Will the issue occur if you create a new list?

    You can save this list as a template (include content) and create a new list, then test whether this issue occurs.

    Thanks,

    Dean Wang


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by VictorVP Wednesday, March 1, 2017 5:02 PM
    Wednesday, February 22, 2017 7:35 AM
    Moderator
  • Hi Dean,

    it is magic :)

    I did as you say "Please try to republish the reusable workflow and access the problematical list ..."

    and now I see reusable workflow in workflow list for problem list

    Thanks a lot :)

    but

    I did the same earlier. Only one difference I did Publish and than Save. It is surprise for me, I spent 3 days for it.

    and about create template from problem list, this list has about 3500 items now, I can create template only with  sceleton without data.

    Wednesday, February 22, 2017 5:54 PM
  • Hi,
    Is there any update?
    If my reply is helpful to you, you can mark as answer.
    Thanks,
    Dean Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    • Marked as answer by VictorVP Wednesday, March 1, 2017 5:02 PM
    Monday, February 27, 2017 1:38 PM
    Moderator