locked
Query on Proclarity 6.3.2217 with SP2 desktop tool RRS feed

  • Question

  • Hi,

    I am facing issues with Proclarity 6.3.2217 with SP2 desktop tool.

    Problems:

    1) I have ProClarity book developed on proclarity 6.32217 querying a 2008 cube. I noticed that on the 2008 cube the Options/Non Empty Crossjoin box is checked when the grid is filtered. But when I "uncheck" the box it does not stick.  I can uncheck it and the rows are still filtering empties.  I go back to the option and it is checked again.

    Because of this issues query is returning a huge dataset and due to huge dataset proclarity tool throws an error as follows:” Query Failed"

    2) When I tried to publish the same proclarity book on web (i.e. on PAS server) it throws an error following error when I was browsing for data.

    Error when accessing page "Report" ({A7F0B84F-8FC9-4134-B4A7-F3F9F4415E61})

    from book "ProclarityReports" ({95357562-05E8-45F6-A765-2D203FD3B8DE})

    Cache File Name:  (unknown)

    Call Stack:

    Location: line #14874 of file QueryImpl.cpp

     - Error-code: (0x1b), Error-number: 0x800f000a

     - Error on executing command query

    Location: line #14339 of file QueryImpl.cpp  

     - Error-code: (0x1b), Error-number: 0x800f000a

    Query Connection XML:

    <ConnectionInfo><Provider Name="{176941F9-18E8-47D6-860D-006FF2655608}" Caption="MSOLAP"/><Server Name="aaa001"/><Catalog Name="DW_Reports_OLAP"/><Cube Name="[DW_Reports]" Caption="DW_Reports"/><Schema Name=""/><LocalServer Name="aaa001"/></ConnectionInfo>

    Can you help me around the above problems? Is there any hot fix around proclarity to resolved issues around "Non Empty Crossjoin" option?

    Wednesday, March 4, 2009 5:20 AM

All replies

  • Hi,

    Have you try to change the OLAP Provider on the ProClarity Options menu to Microsoft OLEDB Provider for Analysis Services 10.0 . Mine was pointing to 9.0 and i had the similar problem with "Use NOn-empty crossjoin" checkbox. After I changed the OLAP provider to 10 , it seemed the unchecked option worked.

    Ali
    Wednesday, March 4, 2009 3:43 PM
  • Hi,

    I think ProClarity Desktop Professional only supports OLEDB Provider 8 and 9. So I am not able to change it to OLEDB Provider 10.


    Thursday, March 5, 2009 4:26 AM
  • Hi,

    I tried with selecting Microsoft OLEDB Provider for Analysis Services 10.0. But the problem remains the same.Non Empty Crossjoin check box check/uncheck does not work.Even if I "uncheck" the box it does not stick to uncheck.If I go back to the option ,it shows checked again.
    Thursday, March 5, 2009 1:59 PM
  • Hi ,
     I know this is obvious but when you open that book and then changing the check box  to un check are you going to book and save the book again replacing the old one? Because if you don't . Old version of the book with checked box will persist.

    Good luck
    Ali
    Friday, March 6, 2009 3:12 PM
  • Hi Guys,

    Even I am getting this error:

    Error from Event-viewer from Machine Where ProClarity Server Installed and running: Sometimes I am getting below error and sometimes It is working fine.

    Any Idea what causes issues?

    Error when accessing page "Book" ({3B9BAED3-DE31-40A7-92DD-06774BE88B22})
    from book "{AAAC0822-3301-4c01-8ADD-1FBA1C0CCF6C}S-1-5-21-666406565-2853157457-2341909388-439530" ({6027BCA1-8AFF-4DD5-89FA-209FB4F2F893})

    Cache File Name:  (unknown)

    Call Stack:

    Location: line #14874 of file QueryImpl.cpp
     - Error-code: (0x1b), Error-number: 0x800f000a
     - Error on executing command query

    Location: line #4491 of file QueryImpl.cpp
     - Error-code: (0x1b), Error-number: 0x800f000a


    Thanks Shiven:) If Answer is Helpful, Please Vote

    Monday, October 20, 2014 3:54 AM