SharePoint 2013 is not compatible with iOS 8 RRS feed

  • Question

  • our users upgraded to iOS 8. After they upgraded to iOS 8, they could not access to SharePoint 2013 site.
    Thursday, September 18, 2014 1:59 PM

All replies

  • http://technet.microsoft.com/en-us/library/fp161353%28v=office.15%29.aspx

    Mobile device browsers supported in SharePoint 2013


    5.0 or later versions

    Video play experience requires iOS version 6.0 or later.




    Office Web Apps full functionality is supported on iPad versions 2 and 3 using iOS 6.0 or later versions. Limited viewing and editing functionality is also supported on iPad versions 1, 2, 3 using iOS version 5.1.         

    If this helped you resolve your issue, please mark it Answered

    Thursday, September 18, 2014 2:34 PM
  • That article was based on 12/18/2013.  iOS 8 was just released yesterday(9/17/2014)
    • Edited by Chenggui CHU Thursday, September 18, 2014 2:56 PM
    Thursday, September 18, 2014 2:38 PM
  • The issue is that ios8 safari does not handle the ntlm challage/response for passwords correctly.  What is interesting is if you install google chrome on your ios8 device, google will work correctly, but it runs sharepoint in desktop mode.

    This tells me that you can update the sharepoint browser support to recognize safari for ios8 and treat it differently that what is defined out of the box.  we have not tried this yet but its our next step.

    Thursday, September 18, 2014 3:40 PM
  • ios8 safari does not handle the ntlm is causing this issue.

    If this helped you resolve your issue, please mark it Answered

    Monday, September 22, 2014 7:37 AM
  • Steven,

    Did you try to update SharePoint browser support, and did it resolve the issue?

    Tuesday, September 23, 2014 3:11 PM
  • It is not SharePoint - it is any web app that uses IIS and Windows Authentication.

    This was broken when iOS 7 was released and was not fixed until iOS 7.0.3.

    Now it is broken again in iOS 8.  The problem is Safari.  It works fine under iOS 8 when using Chrome.

    Unfortunately, Apple does not allow you to set your default browser, so anything like a hyperlink in an email will always go to Safari.

    Some threads on Apple's discussion board:



    Tuesday, September 23, 2014 3:21 PM
  • Hi,

    Please try below option to load site correctly

    Issue: SharePoint site is not working with iOS 8 Safari browser in iPhone.

    Resolution: Load SharePoint site in iOS 8 by tapping the address bar on the broken page then tap at the top of the screen in the status bar. Tap request Desktop Site and the SharePoint site is displayed correctly. 


    Soni K

    Monday, September 29, 2014 2:10 PM
  • This makes no difference for us. Still doesn't work.

    Since it never gets to the SharePoint site, you have no opportunity to reload it.. It is not a "broken page"... It simply never displays.

    • Edited by Stoonad Monday, September 29, 2014 2:15 PM
    Monday, September 29, 2014 2:13 PM
  • For us this was broken page and when we have opted this option the site is rendering properly.


    Soni K

    Monday, September 29, 2014 2:21 PM
  • Are you using Windows Authentication or Forms Based Authentication?
    Monday, September 29, 2014 2:24 PM
  • It's windows authentication.
    Monday, September 29, 2014 4:54 PM
  • Does anyone know when this will be resolved? This is critical for us.


    Sunday, October 12, 2014 10:48 PM
  • I read reports on an Apple forum that it is fixed in the iOS 8.1 beta (but also read someone say it is not...).

    I think iOS 8.1 is going to be released on October 20.

    Sunday, October 12, 2014 11:55 PM
  • It is advisable to move over to Kerberos and Claims Based Authentication. It will save you a lot of headaches, and it reduces the traffic from Client to SharePoint to Active and Back.
    Monday, October 13, 2014 12:11 AM
  • That has nothing to do with the problem. We use Kerberos and Claims. iOS 8 Safari does not work with any site that uses Windows Authentication. Not only SharePoint. Chrome for iOS 8 works.   Safari in iOS 7 works.
    Monday, October 13, 2014 12:24 AM
  • We changed the configuration with the help from Microsoft and finally solved the problem. Here is the instruction:

    Configuration instruction

    • Edited by Chenggui CHU Wednesday, October 15, 2014 12:57 PM
    Wednesday, October 15, 2014 12:55 PM
  • i could not open the link , it give me login  fail for usalife...


    Monday, March 16, 2015 8:56 AM
  • Hello Chenggui,

    Is it possible for you to provide 'Configuration Instruction' in this thread as link is not working. I would really like to know about these configuration changes as our client is facing similar problem where double authentication pop up appears using Safari browser (version 8.1 onward) on iPhone. So it is clear that Safari browser has problem, but to mitigate the issue there should be some alternative. Please provide instructions. Thank You!

    Tuesday, March 24, 2015 8:17 PM
  • We changed the configuration with the help from Microsoft and finally solved the problem. Here is the instruction:


    Hi Chengui, could you please provide the configuration instruction. The link is not accessible.
    Thursday, May 7, 2015 12:21 PM
  • 8.4 was just released.... I am downloading it now.
    Tuesday, June 30, 2015 3:52 PM
  • In case anyone else is looking, I think the document Chenggui was intending to link can be found on this page:  http://www.emiccorp.com/blogs.html

    I haven't attempted the instructions so i can't comment yet whether it resolves my issue.

    • Edited by SPFanGirl Thursday, August 27, 2015 7:08 PM spelling of username
    Thursday, August 27, 2015 7:05 PM