locked
Vista Backup Restore Center shows wrong backup location after change - while executing new backup RRS feed

  • Question

  • Hi,
    Running Vista Ultimate x64 and have noticed this annoying problem a few times.  I have my file backup set to go to the E: drive but changed the settings to send the backup to the F: drive.  The backup location in the Control Panel\System and Maintenance\Backup and Restore Center window shows the backup is in progress, the last successful backup timestamp and next backup (in progress) correctly but it still shows the Backup Location as the E: drive.  However the location is shown correctly for the currently running backup in the Backup Status and Configuration window.

    After the backup completes the Control Panel\System and Maintenance\Backup and Restore Center window is updated to the correct value but showing the wrong value while executing seems incorrect to me.

    I'm sure this is just a small cosmetic issue that was overlooked but it's the kind of issue that makes the otherwise excellent backup and restore function less approachable for non-technical users.  How do I bug this to the right team without using up one of my support incident credits?

    Thanks,
    Rob
    Tuesday, March 17, 2009 4:38 PM

Answers

  • Hi robcohen,
    yes i could see the issue. Firstly i guess you have swapped the two window names. Backup status and configuration window(BSCW) is the one showing backup is in progress and which is showing the old target name.

    This is because of the way these two UIs are implemented. Backup and restore center always listens to the registry. This gets updated as soon as the registry gets updated, hence the updated value.
    But BSCW is updated only after the backup is complete, hence during the backup it shows old value.

    we have addressed this is win7 where we have a single UI which gives the updated value always. Do try the improved backup and restore in win7.

    Thanks,
    Lokesh
    Monday, April 6, 2009 10:13 AM

All replies

  • Lokesh will attempt to reproduce this locally and confirm. We will see that it can be addressed in future release. thanks for the feedback.
    User like you are encouraged to participate in the beta testing of the windows releases and provide valuable feedback. watch out http://connect.microsoft.com/


    ------- this information is provided as-is without any warranties, implicit or explicit.
    Saturday, March 21, 2009 11:33 AM
  • Hi robcohen,
    yes i could see the issue. Firstly i guess you have swapped the two window names. Backup status and configuration window(BSCW) is the one showing backup is in progress and which is showing the old target name.

    This is because of the way these two UIs are implemented. Backup and restore center always listens to the registry. This gets updated as soon as the registry gets updated, hence the updated value.
    But BSCW is updated only after the backup is complete, hence during the backup it shows old value.

    we have addressed this is win7 where we have a single UI which gives the updated value always. Do try the improved backup and restore in win7.

    Thanks,
    Lokesh
    Monday, April 6, 2009 10:13 AM