none
[SharePoint Online/Office 365] New List/Library View Missing "New" Button in Command Bar

    Question

  • Hi,

    In one of our SharePoint sites in Office 365, viewing any list/library with the new 2016 experience does not show the "New" button on the command bar:

    However, setting the view back to the 2013 experience will show the new button:

    The account used for testing is a site collection administrator. This is only happening on lists & libraries on a specific site, with unique permissions from its parent. Other sites (and subsites of this site) do not have this problem.

    Any assistance would be appreciated.

    Friday, September 16, 2016 1:11 AM

All replies

  • Hi Alexander Velasco,

    Per my test in my SharePoint online environment, the “New” button is in the command bar in the new design in library or list with unique permission.

    For troubleshooting the issue, you could check things below:

    1. Check the permission of the account in the library or list with the unique permission.

    2. Delete the unique permission to check if the same issue will occur.

    You could consider using the classic 2013 experience in the library or list which has the issue.

    More reference:

    Modern document libraries in SharePoint.

    https://blogs.office.com/2016/06/07/modern-document-libraries-in-sharepoint/

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com


    Monday, September 19, 2016 3:14 AM
    Moderator
  • Hi Alexander Velasco,

    How is everything going?

    Is there anything update about this issue?

    If the reply is helpful to you, you could mark the reply as answer. Thanks for your understanding.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, September 26, 2016 1:16 AM
    Moderator
  • The library does not have unique permissions, but the New button has already appeared in the 2016 view without any client-side changes. Thank you for the assistance anyway.

    Monday, September 26, 2016 11:54 PM
  • Hi Alexander Velasco,

    If the reply is helpful to you, you could mark the reply as answer. Thanks for your understanding.

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, September 30, 2016 9:41 AM
    Moderator