locked
The windowsemailaddress property for O365 users RRS feed

  • Question

  • Hello,

    I'm hoping someone here can help me, as trying microsoft support is about as effective as banging my head against a wall.

    I have about 1750 users for a customer that want to start using skype for business online, for this i set up a sync to export their users to the required azure tenant, that's all working fine.

    The problem is the integration with outlook, it keeps telling the test users the email account used in skype is different then the one used in outlook, which actually isn't true, but it reads the windowsemailaddress property on the O365 account, which isn't getting filled by the sync. (i would've thought the AD attribute Mail would be synced for this?)

    (i got this info from support-ms-com/en-us/help/2436962/-there-was-a-problem-connecting-to-microsoft-office-outlook-error-whenLync uses the WindowsEmailAddress or MAIL attribute to determine which Exchange server Outlook should connect to. If Lync makes that connection through Exchange Autodiscover and Exchange Web Services (EWS), and if Outlook is configured for another user’s mailbox, Lync registers that as a problem and returns this error.  )

    the problem is so far i've only been able to find the set-mailbox cmdlet to use to set this property, but this fails as the customer doesn't have an exchange online subscription, and thus no mailbox.

    exchange online isn't an option, and due to our multitenancy setup i can't really use an on-premise SfB server either, would anyone have a suggestion on how i can either fill this property or another way i can use to tell skype online where to find our mail servers?

    Wednesday, January 17, 2018 10:31 AM

Answers

  • I've got the proxyaddresses attribute filled, SfB won't log in without it, but that msRTCSIP attribute doesn't exist in the AD schema unless you have your own on-prem skype server, which isn't an option as they removed the ability to filter contact lists and such, making it useless for multitenant environments.

    I've found something about linking it to a resource domain, i'll give that a try.

    • Marked as answer by Duwe1 Wednesday, January 24, 2018 9:36 AM
    Wednesday, January 24, 2018 9:36 AM

All replies

  • Hi Duwe,

    You want to use skype for business online and exchange on-premise environment,after integrating SFB online and exchange on-premise,Outlook  keeps telling the test users the email account used in skype is different then the one used in outlook,you have multi-tenancy ,but the skype for business online donnot support the muti-tenancy,it is only supported in a single Office 365 tenant,so you cannot set the sip address is same to the SMTP address.it is by design.



    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Thursday, January 18, 2018 2:51 AM
  • Well, i do have a single O365 tenant for the customer, it's our on premise AD that's set up for multitenancy.

    The O365 tenant is specifically for them, i've linked their domain name for authentication through adfs, all of that works well, it just won't look for our exchange servers to find the mailboxes for these users.

    the sip and smtp addresses are the same aswell, the problem seems to be that SfB looks at a different attribute to determine which address is used then everything else does?

    Thursday, January 18, 2018 6:53 AM
  • Hi Duwe1,

    Based on my research, I find following attributes will affect the sign in address.you could open user’s properties in AD Users and Computers.

    Regards,

    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, January 23, 2018 7:36 AM
  • I've got the proxyaddresses attribute filled, SfB won't log in without it, but that msRTCSIP attribute doesn't exist in the AD schema unless you have your own on-prem skype server, which isn't an option as they removed the ability to filter contact lists and such, making it useless for multitenant environments.

    I've found something about linking it to a resource domain, i'll give that a try.

    • Marked as answer by Duwe1 Wednesday, January 24, 2018 9:36 AM
    Wednesday, January 24, 2018 9:36 AM
  • Ok,thanks for your update.

    Best Regards,
    Leon Lu


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Friday, January 26, 2018 9:21 AM