locked
Vista cannot connect to a server even if firewall is turned off, but XP can. RRS feed

  • Question

  •  

    Hello,

     

    I am using a Team Foundation Server through HTTP. From my laptop with XP it can be reached easily - for example when I enter the http://serverIP:numberOfPort in the Internet Explorer, the browser asks me for a password and if I fail to log it shows that the Access is denied.

     

    When I connect a laptop with Vista and do the same, a browser just informs that it cannot display the page. I can't also connect to the server via telnet. The behaviour is the same also when I turn off the firewall on Vista (on XP I do not need to turn off the firewall). What then can be blocking this connection?? Are there any security settings that I should check?

    The port number is 9200.

     

    There is no problem to connect to the Web server from the same network as this TFS.

     

    I would be very thankful for some help or suggestions.

     

    Greetings,
    Polo

    Wednesday, July 16, 2008 4:21 PM

Answers

  • Hi,

     

    For the Team Foundation Server related issue, I suggest that you submit it in the Team Foundation Server related forum. The support professionals there are better qualified for assistance.

     

    For your convenience, I’ve included the website of Team Foundation Server forum:

     

    Visual Studio Team System

    http://forums.microsoft.com/msdn/default.aspx?ForumGroupID=5&SiteID=1

     

    Team Foundation Server - Team System Web Access

    http://forums.microsoft.com/msdn/ShowForum.aspx?ForumID=1466&SiteID=1

     

    Additionally, based on my research, this issue can be due to the antivirus software blocking the connection. If there is antivirus software installed on the Windows Vista machine, please temporarily uninstall it and check the result.

     

    Thank you for your understanding and cooperation.

     

    Friday, July 18, 2008 7:35 AM
    Moderator
  • Thanks for help and suggestions. Unfortunately, uninstalling AV did not help.

     

    I just want to write here, for anyone who have a similar problem, that we found the solution: the administrator changed the port number on the server and now it works. However, I have no idea what kind of restrictions are there on the server that it connected from XP and did not want to connect from Vista. Vista perhaps sends different TCP packages or something... Don't know... A bit more detailed discussion may be found here: http://www.vistax64.com/network-internet/168451-vista-cannot-connect-server-via-http.html

     

    And just to explain why I wrote it on the security and not TFS forum: The issue is very loosly related with TFS, as this is just a question of connecting with a http server. Well it is in fact even a question of connecting to the TCP server. I thought it is related with some security settings on my laptop. It seems that it is maybe more with networking.

    Tuesday, July 29, 2008 2:27 PM

All replies

  • Ensure that Network Discovery is turned on.

     

    Wednesday, July 16, 2008 6:07 PM
  • Unfortunatelly it didn't help.

    To be clear: I am not in the network (local nor VPN) with the server I want to connect to. I use its public IP.

     

    Thursday, July 17, 2008 6:57 AM
  • Hi,

     

    For the Team Foundation Server related issue, I suggest that you submit it in the Team Foundation Server related forum. The support professionals there are better qualified for assistance.

     

    For your convenience, I’ve included the website of Team Foundation Server forum:

     

    Visual Studio Team System

    http://forums.microsoft.com/msdn/default.aspx?ForumGroupID=5&SiteID=1

     

    Team Foundation Server - Team System Web Access

    http://forums.microsoft.com/msdn/ShowForum.aspx?ForumID=1466&SiteID=1

     

    Additionally, based on my research, this issue can be due to the antivirus software blocking the connection. If there is antivirus software installed on the Windows Vista machine, please temporarily uninstall it and check the result.

     

    Thank you for your understanding and cooperation.

     

    Friday, July 18, 2008 7:35 AM
    Moderator
  • Thanks for help and suggestions. Unfortunately, uninstalling AV did not help.

     

    I just want to write here, for anyone who have a similar problem, that we found the solution: the administrator changed the port number on the server and now it works. However, I have no idea what kind of restrictions are there on the server that it connected from XP and did not want to connect from Vista. Vista perhaps sends different TCP packages or something... Don't know... A bit more detailed discussion may be found here: http://www.vistax64.com/network-internet/168451-vista-cannot-connect-server-via-http.html

     

    And just to explain why I wrote it on the security and not TFS forum: The issue is very loosly related with TFS, as this is just a question of connecting with a http server. Well it is in fact even a question of connecting to the TCP server. I thought it is related with some security settings on my laptop. It seems that it is maybe more with networking.

    Tuesday, July 29, 2008 2:27 PM
  • I believe I'm having the same problem. I believe I'm having problems with accessing another network through my computer (i say believe, because I'm not very knowledgeable about the intricacies of computers). I'm trying to access my personal account on the university i attend and of course I get the error message when I try to access it. Works on other computers though.

    I've tried several solutions included checking for spyware, turning off windows firewall, resetting and reinstalling winstock through command prompt. predictably none of it worked. So that's why I believe I have the same issue. That being said, I don't understand what you mean when you say, "I just want to write here, for anyone who have a similar problem, that we found the solution: the administrator changed the port number on the server and now it works."

    By administrator do you simply mean administrator of the computer? If so - and I am the administrator of my computer - how do I change the port number on my server?
    Monday, August 10, 2009 10:02 PM