none
Hyper-V Host with VLAN Trunk. Not accepting Trunk traffic..

    Question

  • Trying to get VLAN & Trunking to work in Hyper-V. 

    I have two VM's on the same Network. SCVMM and Host1. Host1 should be a Trunk for VLAN 7-12 and Native VLAN 10. I then put SCVMM on VLAN7 via the GUI. Does not work! If I set Native Vlan to 7 it works. If I not use Trunking it works (both VMs on VLAN 7). 

    VMName VMNetworkAdapterName Mode     VlanList
    ------ -------------------- ----     --------
    Host1  Network Adapter      Trunk    10,7-12
    Remote Network Adapter      Untagged
    Remote Network Adapter      Untagged
    RRAS   Network Adapter      Untagged
    RRAS   Network Adapter      Untagged
    RRAS   Network Adapter      Untagged
    RRAS   Network Adapter      Untagged
    SCVMM  Network Adapter      Access   7
    SCVMM  Network Adapter      Untagged
    SCVMM  Network Adapter      Untagged

    What Am I doing wrong, or not understanding?

    Its this LAB I am setting up.
    https://blogs.msdn.microsoft.com/excellentsge/2016/10/06/deploying-sdn-on-one-single-physical-host-using-vmm/

    Sunday, February 5, 2017 9:48 PM

All replies

  • Hi Wldnet,

    >>I then put SCVMM on VLAN7 via the GUI. Does not work!

    Perform a network capture on both VMs for detailed analysis. Find out where is the problem.

    Here is the link of network monitor:

    http://www.microsoft.com/en-us/download/details.aspx?id=4865

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, February 6, 2017 6:01 AM
    Moderator

  • It looks to me the VM's VLAN in range of AllowedVlanIdList can not talk to each other. The VMs on NativeVlanId can talk to each other. Am I missing something?

    When wiresharking I see nothing icmp related.

    Monday, February 6, 2017 11:16 AM
  • Hi,

    >>It looks to me the VM's VLAN in range of AllowedVlanIdList can not talk to each other. The VMs on NativeVlanId can talk to each other.

    Then phenomenon seems strange.

    >>When wiresharking I see nothing icmp related.

    On the vm which you are pinging from, the packets were not sent out?

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, February 7, 2017 6:20 AM
    Moderator
  • Hi,

    I noticed you deleted your replies. How about the situation now?

    Best Regards,

    Leo


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 2, 2017 7:44 AM
    Moderator