locked
Trouble installing a *.msi file on Windows 7 to a directory of my choosing? RRS feed

  • Question

  • I'm having trouble installing a *.msi file created under Microsoft Visual Studio.Net 2005 on a Windows 7 machine.  The problem occurs when I attempt to provide a directory for installation, but the installation wizard always defaults to the C: root folder.  I can always move the created files and folders from the *.msi wizard to a directory of my choosing and run the tool successfully.  But, I'm confused has to why the *.msi wizard always defaults to the C: root.

    I have tried running the *.msi file in administrative mode using the various published methods but none of those methods are made available, in fact they are all disabled.  I.e. right click the *.msi file has a disabled "Run as Administrator" option.  The properties under the *.msi file to "Run As Administrator" is also disabled.  And running the *.msi file under msiexec as also proven unsuccessful.

    Can someone point me in the right direction?

    • Moved by Carey FrischMVP Friday, October 8, 2010 6:41 PM Moved to appropriate forum category (From:Windows 7 Installation, Setup, and Deployment)
    Friday, October 8, 2010 6:18 PM

Answers

  • Hi, thank you for posting here.

     

    Did this issue appeared on other .mis file? I suggest you asking Visual Studio Forum for further help:

     

    Visual Studio

     

    The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.  Thank you for your understanding.

     

     

    Regards,

    Leo   Huang


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Leo Huang Monday, October 18, 2010 12:56 AM
    Monday, October 11, 2010 7:33 AM