locked
XAMPP issues starting up Apache RRS feed

  • Question

  • 8:12:27 AM  [Apache] Problem detected!
    8:12:27 AM  [Apache] Port 80 in use by "Unable to open process" with PID 4!
    8:12:27 AM  [Apache] Apache WILL NOT start without the configured ports free!
    8:12:27 AM  [Apache] You need to uninstall/disable/reconfigure the blocking application
    8:12:27 AM  [Apache] or reconfigure Apache and the Control Panel to listen on a different port
    8:12:27 AM  [Apache] Attempting to start Apache app...
    8:12:27 AM  [Apache] Status change detected: running
    8:12:28 AM  [Apache] Status change detected: stopped
    8:12:28 AM  [Apache] Error: Apache shutdown unexpectedly.
    8:12:28 AM  [Apache] This may be due to a blocked port, missing dependencies, 
    8:12:28 AM  [Apache] improper privileges, a crash, or a shutdown by another method.
    8:12:28 AM  [Apache] Press the Logs button to view error logs and check
    8:12:28 AM  [Apache] the Windows Event Viewer for more clues
    8:12:28 AM  [Apache] If you need more help, copy and post this
    8:12:28 AM  [Apache] entire log window on the forums

    Before anyone answers the obvious I did change the port from 80 to 8080 since it was being used by system. 

    I also changed the ssl config port from 443 to 4443. 

    any other suggestions? I am trying to get this php code running so I can get a job help is appreciated.

    Friday, September 1, 2017 12:21 PM

All replies

  • Sorry to bug everyone, sometimes a good night sleep brings enlightenment. I was using port 8080 and Tomcat uses Port 8080, so I changed to 8081 and low and behold it is running now. I will move on see if I can get this job I so desperately need now.

    Thanks

    Friday, September 1, 2017 12:29 PM