locked
Installer 4.5 requirements state for Vista Service Pack 1 only? RRS feed

  • Question

  • I've read every post on Windows Installer - took a while dating back to 07'.

    My problem doesn’t quite fit anything mentioned. I have a fresh "clean" install as of a month ago. I have Vista HP 32bit. I had no problem getting it to the point where it finally said, "Up to Date" except a lot of hours and making sure categories and date orders of the updates were correct. Now for my problem.

    I do a lot of video authoring and work with various video file types. lately two things have been happening.

    1) in the properties on folders myself, admins and system is listed with full privilege, but "everyone" is showing up at the top of the list with all privileges denied. This effectively locks me out of the folder like My Pictures or My Documents, even Public folders. MSS, Kaspersky and Malwarebytes found nothing and all hardware and memory diagnostics check out. New fans, power supply, Video card, memory modules, and hard drives. Vary annoying.

    2) Lately, I've been having problems with Windows Installer popping up when accessing video clips of feeds. Running PC5 and checking the video D/A input device I pressed the test button and Windows Installer popped up stating "please wait while Windows configures Studio 15". If I cancel the video clip plays fine. If I allow it to complete it's "configuration" another dialog pops up asking me to put in the correct disk in drive 1. When I cancel this I get Error Msg 1706 No valid source could be found for product Studio 15 The Windows Installer cannot continue. Installer performs a rollback, all dialog boxes vanish, then the video clip plays fine. again annoying. More importantly, it interferes with every device and software I have that uses video - a lot! This prevents me from doing my work, no work - no income, no income - I don't buy Microsoft products...  no pressure...

    Now, I noticed in the download section there are several Windows Installers. In particular 4.5 redistributable. I have no interest in distributing software so using the DLL's is moot. There are also at least two (2) patches for this service. All system requirements state Vista SP-1.

    Will Windows Installer 4.5 redistributable work to correct my problem to the best of your knowledge?

    Does it pose a problem that system requirements state Vista SP-1 when I have SP-2 installed?

    Will this replace msiexec (MSISERVER)?

    Can it be rolled back if a problem shows up?

    MSISERVER is currently set as:

    C:\windows\system32\msiecec/v

    Local account, Undocked enabled

     

    Thanks

    Thursday, June 23, 2011 7:52 PM

Answers

  • Hi,

    Windows Installer will take affact when you install\uninstall software. If you can install service pack 2 successfully, that means Windows Installer is working properly.

    Please update your video D/A input device and all the software related.

    As to the first permission issue, please create a new user account in case the profile is corrupted.

    Regards,

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, June 29, 2011 8:48 AM
    Moderator