locked
windows update and a missing .net framework file RRS feed

  • Question

  • Hi,

    I have read the mesages about the failure to update and I am having the same problem. I also recently had to put in a new hard drive and as im trying to reload everything back up is when i notice something going on. First I cannot do an update either. I also was trying to load the software for Seagate external harddrive and it says that it needs the MS.netframework 4.0 client file. When it starts to load up the files that it needs to run the program it stops when it gets to that file and it says failed to load. An error code 1920  Not sure what to do about that. I still don't have my seagate software loaded. PLease advise any help would be appreciated. My system is Win 7 64 bit Prem

    Tuesday, March 25, 2014 1:47 AM

All replies

  • Hi,

    I am confused about your vague description.

    I have read the mesages about the failure to update

    What message did you read? Please let us know the exact error message of the Windows Update.

    Microsoft .NET Framework 4 download address is below:

    http://www.microsoft.com/en-in/download/details.aspx?id=17851


    Karen Hu
    TechNet Community Support

    • Edited by Karen Hu Wednesday, March 26, 2014 1:54 AM update
    Wednesday, March 26, 2014 1:44 AM
  • Hello, Thanks for responding. I may have a few different things going on here not sure. First I cannot do updates on my computer for some reason. When I try to it says Windows update cannot currently check for updates because the service is not running, you may need to restart computer. The service is running because i checked in the services area. Second I tried to download the .NET framework thru the link that u posted here and it downloads ok but then it fails to install and gives the error message HRESULT 0xc8000222 and says failed to install. Thirdly I have a couple of programs that I am rtying to reload since i replaced my harddrive and they will not download because they say that they need a signed driver. I have gone into the sites directly and  download it right from the site and they still fail to download, One is a wireless usb adapter it gives me this message it is trying to install an unsigned driver and it may not work correctly. I had this same program on this win 7 computer before i put in a new hardrive and it worked fine--never had any error message trying to install it. The other program is a Seagate portable hardwdrive and it will not load up either i think partially due to the  .net framework not installed because it stops there when trying to install it prior to installing the software for it. It then says error 1920 dashvoard service failed to start, veryify that you have sufficient priveliges to start system service. PLease advise Im not sure what to do about all these and its driving me crazy. Thanks
    Sunday, March 30, 2014 12:08 AM