locked
IE 10 in Captured OSD WIM will not launch on certain platforms RRS feed

  • Question

  • All,

    I've been fighting this issue for a couple of months now. I have an active case that I've opened with Microsoft recently that I am still working on them with.

    For some background, I have a Windows 7 SP1 OS WIM that was built and captured via SCCM on a VMWare platform. It includes all patches up through February 2014. This also includes Internet Explorer 10 via the WSUS update. We are NOT installing IE 11.

    The build and capture sequence finishes without error and I've imported the OS WIM into SCCM for deploying.

    This is where issues start on some of our systems.

    We support about 35 models. On certain models, Internet Explorer 10 will not launch. In addition, we get the dllhost.exe memory leak issue (where it keeps spawning a process). The ONLY common thread I can determine is that they have a discrete nVidia GPU.

    The models are as follows:

    HP EliteBook 8770w - Quadro K5000M
    HP ZBook 17 - Quadro K4100M
    HP Z600 - Quadro 5000
    HP Z820 - Quadro 6000
    Dell Precision R7610 - Quadro NVS310

    Each one of these systems, as stated, complete the imaging process fine and everything else appear to be running without issue. I've even cut the driver package back to only including a network and storage driver and the issue STILL happens.

    Has anyone else seen or experienced this issue and have a solution? I've had some success with uninstalling the KB2670838, rebooting, reinstalling KB2670838 and then reinstalling IE 10. After doing that, it appears to function properly.

    Friday, March 7, 2014 4:47 AM

All replies

  • Hi,

    So far, we haven't receive familiar issue. 

    Did you tried to deploy image only included the Internet Explorer 10 without this update?

    Please follow this description to article to check your settings:

    http://support.microsoft.com/kb/2670838

    If the issue still persists, I would like to suggest you push this update separately after deployment.


    Karen Hu
    TechNet Community Support

    Monday, March 10, 2014 1:02 PM
  • On certain models, Internet Explorer 10 will not launch.

    What happens to it?  Use ProcMon to see.  One known cause is trying to move the %ProgramFiles% directory out of the %SysDrive% partition.  I think that was in an early W8.  I haven't checked to see what happens in W8.1 but that would be IE11 anyway.  Another previously seen cause is misconfigured security, such as Windows Live Family Safety.


    Robert Aldwinckle
    ---

    Monday, March 10, 2014 4:15 PM
    Answerer
  • Karen,

    The update is a pre-req to installing IE 10. Therefore, I cannot try to install IE 10 without the update being on the machine.

    Monday, March 10, 2014 4:34 PM
  • Robert,

    Not dived deeply into ProcMon yet on this issue. I do have a support case open with Microsoft and the ball is currently in their court.

    Also, I'm dealing with Windows 7 SP1 x64 Enterprise and not Windows 8.0 or 8.1. I'm not familiar with the Windows Live Family Safety, but I'm not thinking that is an issue for me at this time. Thanks for the input though.

    Monday, March 10, 2014 4:38 PM
  • Hi James

    Is there anything to indicate that the B&C WIM is at all related to the issue?

    I know that IE uses GPU acceleration, so is this potentially just a graphics driver + IE compatibility issue?

    To test that you could trying a new/older driver - or even shift+deleting the driver so its removed from the device (tick the tick box), and they use the built in one.

    Thursday, March 19, 2015 12:24 PM
  • Mikhail,

    Hey there. I never did come back to this thread, but even after working with Microsoft for months they were unable to definitely determine what was up. They event sent a specialist out to my office, worked side-by-side with me and deeply analyzed what was going on.

    If I recall correctly, the culprit did point to the IE 10 Pre-req patch KB2670838. Including that patch in the WIM would cause issues with several of our systems when trying to use a unified WIM. So, we install that patch and IE 10 during our provisioning process for Windows 7 systems.

    As for the drivers, the issue would occur even if you gave the machines the basic two drivers it needed (Network and Storage). Removing the video drivers from the equation didn't resolve the issue at all. I know it sounds odd, but the widespread corruption of the registry we were seeing was baffling to say the least. Again, removing KB2670838 (and thus IE 10) from our WIM fixed all of our issues.

    One more thing I wanted to add was that it also (for an unknown reason) caused the local certificate store to be completely deleted on the nVidia based systems. This prevented the SCCM client from installing as it could not validate the signature on the ccmsetup.cab file.

    Again, on systems that were non-nVidia the WIM would deploy and work fine without ANY issues. It is just on those systems with nVidia GPU's that all the odd issues occurred. Why could never be determined. We just finally moved on with a work around.

    Thursday, March 19, 2015 3:18 PM