none
SharePoint 2010 Service Application Load Balancer Endpoint failure RRS feed

  • Question

  • HI,

    I have got 2 server farm:

    Server 1: Sharepoint 2010 + Project Srver 2010 +SP1 + Sep 2012 CU

    Server 2: SQL 2008 R2 + Sharepoint 2010 web fron end + Reporting services + all the required patches

    now for some reason, my client had to change rename the server-1 where central admin and PWA was hosted and working fine.

    I have perfornmed following activiites in order to access the Central admin and PWA to be accessed after rename of server.

    1. Defined AAM for both web apps

    2. create DNS entry to map the IP of server with the new name

    and once the name was changed, central admin and PWA (with little more troubleshooting) has started working.

    Issue:

    While browsing, PWA crashes randomly, see the screen shot below. but it never stuck in the same stage, and soon i click back to home page it starts working.

    also in event log i am getting the following error for several services: (topology, profile, metadata etc. )

    also the bold name of the server in below error is the old name of the server which doesnt exist now.

    __________________________________________________________________________________________

    SharePoint Web Services Round Robin Service Load Balancer Event: EndpointFailure

    Process Name: OWSTIMER

    Process ID: 3888

    AppDomain Name: DefaultDomain

    AppDomain ID: 1

    Service Application Uri: urn:schemas-microsoft-com:sharepoint:service:a6996b19aeb54b42aa89c7ca4f05be32#authority=urn:uuid:3b0051e3de1746388e9f7058222a8e5a&authority=https://dld-epmapptest:32844/Topology/topology.svc

    Active Endpoints: 1

    Failed Endpoints:1

    Affected Endpoint: http://dld-epmapptest:32843/a6996b19aeb54b42aa89c7ca4f05be32/ProfileService.svc

    _________________________________________________________________________

    so its clear that for some reason servic application is trying to look for the old name of the server, and since it couldnt find, its giving error.

    Now, is there a way to update the end point of services which are failing due to this issue? 

    for your record, i have already tried stop/restart solution of the service (as mentioned in other threads) but it didnt worked for me.

    any clues/ideas would be much appriciated, thanks.


    Khurram Jamshed - MBA, PMP, MCTS, MCITP ( Blog, Twitter, Linkedin )

    Wednesday, January 16, 2013 1:25 PM

Answers

All replies