none
Schedule Task within script for import module RRS feed

  • Question

  • Hi,

    Unable to powershell script in Scheduled task. I have added the import AD module in the powershell script.Every time I need to login into Windows 2008 R2 server and then the script runs successfully.. if I log off the server it doesn't runs..

    Do you have any solutions for without login on server the script runs sucessfully

    Regards

    KunalR

    Monday, August 4, 2014 1:28 PM

Answers

  • Hi,

    We can't help you without seeing your script.

    Also, post exactly how you have the scheduled task set up.


    Don't retire TechNet! - (Don't give up yet - 12,950+ strong and growing)

    Monday, August 4, 2014 1:47 PM
  • Hi KunalR,

    adding to Mike, this typically happens when you have set your task to be only executed when the executing user is logged in. This can be configured in the Task Scheduler on the task's properties. Tab "General" (I assume that's what it's called, don't have an English System at hand. By default it's the initially open tab), in the Security Settings you can find the option you are seeking.

    Cheers,
    Fred


    There's no place like 127.0.0.1

    • Proposed as answer by jrv Monday, August 4, 2014 2:13 PM
    • Marked as answer by ScriptingWifeModerator Tuesday, September 16, 2014 7:17 PM
    Monday, August 4, 2014 1:57 PM

All replies

  • Hi,

    We can't help you without seeing your script.

    Also, post exactly how you have the scheduled task set up.


    Don't retire TechNet! - (Don't give up yet - 12,950+ strong and growing)

    Monday, August 4, 2014 1:47 PM
  • Hi KunalR,

    adding to Mike, this typically happens when you have set your task to be only executed when the executing user is logged in. This can be configured in the Task Scheduler on the task's properties. Tab "General" (I assume that's what it's called, don't have an English System at hand. By default it's the initially open tab), in the Security Settings you can find the option you are seeking.

    Cheers,
    Fred


    There's no place like 127.0.0.1

    • Proposed as answer by jrv Monday, August 4, 2014 2:13 PM
    • Marked as answer by ScriptingWifeModerator Tuesday, September 16, 2014 7:17 PM
    Monday, August 4, 2014 1:57 PM