none
Problem setting up BitLocker manage-bde -autounlock via script RRS feed

  • Question

  • Hello guys,

    I am working on an automation script to deploy BitLocker in my entreprise domain but I am stuck on a something and it seems I can't resolve it without your help.

    Everything is working fine except when I try to autounlock my encrypted Data Drive.

    I believe I use the right command and both my C and D drives are crypted before I use it so....

    By the way, the error is

    "Error: Invalid Syntax

    -autolunlock has not been understood"

    The command line is:

    cmd /c "manage-bde –autounlock -enable D:"
    cmd /c "manage-bde -protectors -enable D:"

    I also tried to use Invoke-Expresion (same error).

    Am a bit lost now...

    So could you help me please? :)

    Best Regards,

    Edhalis


    • Edited by Edhalis Thursday, March 23, 2017 1:03 PM
    Thursday, March 23, 2017 1:00 PM

Answers

  • Hi Edhails.

    I am very sure that you simply mistyped it or you copy and pasted the command from some website and the hyphen ("-") was no "real" hyphen on that website.

    Please retry:

    manage-bde -autounlock -enable d:


    • Edited by Ronald Schilf Thursday, March 23, 2017 1:37 PM
    • Marked as answer by Edhalis Thursday, March 23, 2017 4:07 PM
    Thursday, March 23, 2017 1:37 PM

All replies

  • Hi Edhails.

    I am very sure that you simply mistyped it or you copy and pasted the command from some website and the hyphen ("-") was no "real" hyphen on that website.

    Please retry:

    manage-bde -autounlock -enable d:


    • Edited by Ronald Schilf Thursday, March 23, 2017 1:37 PM
    • Marked as answer by Edhalis Thursday, March 23, 2017 4:07 PM
    Thursday, March 23, 2017 1:37 PM
  • Oh god you were right!

    Many thanks. Didn't tought about that :)

    Thursday, March 23, 2017 2:55 PM
  • :-)

    Funny, I had the same problem once...someone had offered a code example and somehow, his website editor had turned the hyphens into a symbol that looked like a hyphen but wasn't one.

    Thursday, March 23, 2017 2:57 PM