Metadata publishing for this service is currently disabled.


  • Hi, 

    I have installed SCSM 2012 on 2012 server. On this machine i installed web content server role as well, while Sharepoint Web part is installed at Sharepoint 2010 machine which is on Windows 2008 R2. After installing Web Content server role when i tried to access following URL


    I got following error:

    This is a Windows© Communication Foundation service.

    Metadata publishing for this service is currently disabled.

    If you have access to the service, you can enable metadata publishing by completing the following steps to modify your web or application configuration file:

    1. Create the following service behavior configuration, or add the <serviceMetadata> element to an existing service behavior configuration:

    <behavior name="MyServiceTypeBehaviors" >
    <serviceMetadata httpGetEnabled="true" />

    2. Add the behavior configuration to the service:

    <service name="MyNamespace.MyServiceType" behaviorConfiguration="MyServiceTypeBehaviors" >

    Note: the service name must match the configuration name for the service implementation.

    3. Add the following endpoint to your service configuration:







    How to resolve this issue? 


    Tuesday, November 05, 2013 11:05 AM

All replies

  • Did you find any solution to this problem? Having the same here...
    Saturday, November 16, 2013 1:32 PM
  • I also get this error when attempting to browse to the SMPortal WebContent server. This has resulted in the Silverlight WebParts not displaying on the SMPortal SharePoint site. Surely we cant be the only three people in the world experiencing this!

    Thursday, February 13, 2014 5:07 PM
  • Any updates on this?  I am receiving the same error.
    Monday, June 23, 2014 8:47 PM
  • Are you trying to get around the error without enabling metadata publishing, or are you unsure how to enable metadata publishing?

    you should only have to look in the web.config in the ServiceHost folder and change:

    <serviceMetadata httpGetEnabled="false" />


    <serviceMetadata httpGetEnabled="true" />

    - Get on the floor, do that dinosaur

    Monday, June 23, 2014 9:32 PM
  • I think there is an issue of context here. why are you attempting to browse to a web service with a browser? This "error" is simply the default response of the web service to a HTTP GET request, that is, "I don't publish metadata. send a real service request".

    if you are unable to see the Silverlight parts, it's probably due to certificate issues, but you might want to go through the whole troubleshooting article.

    Tuesday, June 24, 2014 2:02 PM
  • I have been struggling long time on this issues of smportal silver light not loading and so far nothing has worked for me, google has exhausted with all my searches I have tried wild card, self signed all available link followed, re-install / fresh install however no success, on above solution to add <behavior name=>, can some one tell me what should be behavior type name?? i have added as its is in web.confi but without success.

    Monday, August 04, 2014 12:18 PM