none
Office 365 Trusted Locations Registry settings don't work RRS feed

  • Question

  • Hey Guys

    I'm having an issue with two Office 365 (64 Bit) Business Applications running on Windows 10 64bit. I created a registry file to set a trusted location to a network path. I was able to use it on a different system with the same program, os and hardware, but for some reason it doesn't work on the other two. Here's the reg file i'm using:

    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Excel\Security\Trusted Locations\MyLocation]
    "Path"="Z:\"
    "AllowSubfolders"=dword:00000001
    

    I already activated "Allow trusted Locations on the network" on the "Trusted location" tab. The path just doesn't show up. When I add id Randomly it does show up, but Excel-Files with macros still need to be activated.

    Do you know what I'm doing wrong?

    Thanks for your help.

    Kind regards,

    gabeBU


    Wednesday, October 9, 2019 3:45 PM

All replies

  • Hi gabeBU,

    Are you using mapped drivers? As a side note, it is recommended that you not use the mapped drive but rather the UNC path (such as \\server_name\desired_folder\). Too many issue relate to mapped drives. You may refer to the article Plan and configure Trusted Locations settings for Office 2013 to learn more. The article applies to Office 2013. For Office 365, it's version number is 16.0.

    Based on your description, I don't find anything wrong with the registry settings. It''s right to enable "Allow trusted Locations on the network" (set "AllowNetworkLocations" to "1") if you add network paths as trusted locations. In addition, there are some default key for trusted Locations, such as software\policies\microsoft\office\16.0\excel\security\trusted locations\location1, you can add some keys like "location2","location3"...

    You may check box "Subfolders of this location are also trusted" (set "allowsubfolders" to "1"). As for Excel-Files with macros, please check macro settings in trust center. What's the level under using?

    Hope the information was helpful. Any updates, feel free to post back to let us know.

    Best Regards,

    Herb


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.

    Thursday, October 10, 2019 7:20 AM
    Moderator
  • Hello Herbs

    I'll try again with the direct UMC Path.

    I still have macro-security enabled (default settings), because we don't want the security risks with external Excel-Files.

    Thanks for your help, I'll update you shortly.


    • Edited by gabebu Thursday, October 10, 2019 8:04 AM
    Thursday, October 10, 2019 8:03 AM
  • Hi,

    OK. If you have anything you want share with us, feel free to post back. I would be glad to help you if you need further assistance.

    Best Regards,

    Herb


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Office 2019.

    Friday, October 11, 2019 9:13 AM
    Moderator
  • Hi Herb

    Unfortunately, using the UMC Path didn't work. I'm also not able to select the settings, it seems like that it doesn't add the path properly.

    Do you may have another suggestion?

    THanks for your help.

    Kind regards,

    Gabebu

    Friday, October 11, 2019 12:08 PM