locked
The type initializer for 'Microsoft.Exchange.Configuration.Authorization.InitialSessionStateBuilder' threw an exception. RRS feed

  • Question

  • Hello,

    I installed fresh E2010 on a new VM created from a SCVMM template.

    RSAT was installed, IPv6 is enabled. The installation run smoothly.

    On first EMC openning I get an error:

    The following error occurred while searching for the on-premises Exchange server:

    [e2010.contoso.lan] Processing data from remote server failed with the following error message: The type initializer for 'Microsoft.Exchange.Configuration.Authorization.InitialSessionStateBuilder' threw an exception. For more information, see the about_Remote_Troubleshooting Help topic. It was running the command 'Discover-ExchangeServer -UseWIA $true -SuppressError $true -CurrentVersion 'Version 14.1 (Build 218.15)''.

    What to check?

    Thx.

    Michael.

     


    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis
    Tuesday, October 4, 2011 9:44 PM

Answers

  • Quick question, which Exchange release you installed, I mean Exchange 2010 RTM, along with SP 1 or SP 2.

    The similar kind of EMC opening issue for the first time has been resolved in Exchange 2010 SP1.

    Else, what you can give a try, go to Server Manager, and remove WINRM IIS Extensions, and then restart your server, and once it booted again, install it again and register WINRM as follows by running the COMMAND PROMPT as "Run as Adminsitrator"

    Enabling Windows Remote Management

    Using the command line

    To enable Windows Remote Shell on a server running a Server Core installation, type the following command at the command prompt of the Server Core box:

    WinRM quickconfig

    or (shorter, but with the same effect)

    WinRM qc

    The command questions whether you really want to enable Windows Remote Management:

    WinRM is not set up to allow remote access to this machine for management. 
    The following changes must be made: Create a WinRM listener on HTTP://* to accept WS-Man requests to any IP on this machine 
    Make these changes [y/n]?

    Press y to continue or n to cancel.

    Let;s see if it fixes your issues.

    Zahir 
    Zahir Hussain Shah | MVP - Exchange Server | Senior Infrastructure Consultant - Messaging | My blog: http://zahirshahblog.com ]If my answer fixes your problem, mark them as answer, so it will help others]
    • Proposed as answer by Zahir Hussain Shah Wednesday, October 5, 2011 8:50 AM
    • Marked as answer by Terence Yu Tuesday, October 11, 2011 5:49 AM
    Wednesday, October 5, 2011 8:50 AM
  • Zahir,

    1. for some reason WINRM IIS Extentions were not installed at all

    Installed and restarted the server.

    2. When run Exchange management shell there is bunch of errors (see below).

    3. This is Exchange2010 sp1. There is no SP2 yet. Unless you know ...

    I run this copy 2 weeks ago for different installation. And had no issue.

    The ver shown in my initial post(at the end of the error message) is 'Version 14.1 (Build 218.15)''. It is SP1

     

    4. Since it is lab it not make sense to spent more time for troubleshooting. I will revert DC and Exchange VM and will reinstall E2010.

    I appreciate your input.

    Thanks again.

    Michael.

     

    *****************

    The Exchange types file wasn't loaded because not all of the required files could be found.

             Welcome to the Exchange Management Shell!

    Full list of cmdlets: Get-Command
    Only Exchange cmdlets: Get-ExCommand
    Cmdlets that match a specific string: Help *<string>*
    Get general help: Help
    Get help for a cmdlet: Help <cmdlet name> or <cmdlet name> -?
    Show quick reference guide: QuickRef
    Exchange team blog: Get-ExBlog
    Show full output for a command: <command> | Format-List

    Tip of the day #33:

    Want to create a group of test users in your lab? Use this command:

     1..100 | ForEach { Net User "User$_" MyPassword=01 /ADD /Domain; Enable-Mailbox "User$_" }

    VERBOSE: Connecting to e2010.contoso.lan
    [e2010.contoso.lan] Processing data from remote server failed with the following error message: The type initializer f
    r 'Microsoft.Exchange.Configuration.Authorization.InitialSessionStateBuilder' threw an exception. For more information
     see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    VERBOSE: Connecting to E2010.contoso.lan
    [e2010.contoso.lan] Processing data from remote server failed with the following error message: The type initializer f
    r 'Microsoft.Exchange.Configuration.Authorization.InitialSessionStateBuilder' threw an exception. For more information
     see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    VERBOSE: Connecting to E2010.contoso.lan
    [e2010.contoso.lan] Processing data from remote server failed with the following error message: The type initializer f
    r 'Microsoft.Exchange.Configuration.Authorization.InitialSessionStateBuilder' threw an exception. For more information
     see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    Failed to connect to an Exchange server in the current site.
    Enter the server FQDN where you want to connect.:


    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis
    • Edited by pob579 Wednesday, October 5, 2011 9:27 PM
    • Proposed as answer by Terence Yu Thursday, October 6, 2011 3:01 AM
    • Marked as answer by Terence Yu Tuesday, October 11, 2011 5:49 AM
    Wednesday, October 5, 2011 8:55 PM

All replies

  • Quick question, which Exchange release you installed, I mean Exchange 2010 RTM, along with SP 1 or SP 2.

    The similar kind of EMC opening issue for the first time has been resolved in Exchange 2010 SP1.

    Else, what you can give a try, go to Server Manager, and remove WINRM IIS Extensions, and then restart your server, and once it booted again, install it again and register WINRM as follows by running the COMMAND PROMPT as "Run as Adminsitrator"

    Enabling Windows Remote Management

    Using the command line

    To enable Windows Remote Shell on a server running a Server Core installation, type the following command at the command prompt of the Server Core box:

    WinRM quickconfig

    or (shorter, but with the same effect)

    WinRM qc

    The command questions whether you really want to enable Windows Remote Management:

    WinRM is not set up to allow remote access to this machine for management. 
    The following changes must be made: Create a WinRM listener on HTTP://* to accept WS-Man requests to any IP on this machine 
    Make these changes [y/n]?

    Press y to continue or n to cancel.

    Let;s see if it fixes your issues.

    Zahir 
    Zahir Hussain Shah | MVP - Exchange Server | Senior Infrastructure Consultant - Messaging | My blog: http://zahirshahblog.com ]If my answer fixes your problem, mark them as answer, so it will help others]
    • Proposed as answer by Zahir Hussain Shah Wednesday, October 5, 2011 8:50 AM
    • Marked as answer by Terence Yu Tuesday, October 11, 2011 5:49 AM
    Wednesday, October 5, 2011 8:50 AM
  • Zahir,

    1. for some reason WINRM IIS Extentions were not installed at all

    Installed and restarted the server.

    2. When run Exchange management shell there is bunch of errors (see below).

    3. This is Exchange2010 sp1. There is no SP2 yet. Unless you know ...

    I run this copy 2 weeks ago for different installation. And had no issue.

    The ver shown in my initial post(at the end of the error message) is 'Version 14.1 (Build 218.15)''. It is SP1

     

    4. Since it is lab it not make sense to spent more time for troubleshooting. I will revert DC and Exchange VM and will reinstall E2010.

    I appreciate your input.

    Thanks again.

    Michael.

     

    *****************

    The Exchange types file wasn't loaded because not all of the required files could be found.

             Welcome to the Exchange Management Shell!

    Full list of cmdlets: Get-Command
    Only Exchange cmdlets: Get-ExCommand
    Cmdlets that match a specific string: Help *<string>*
    Get general help: Help
    Get help for a cmdlet: Help <cmdlet name> or <cmdlet name> -?
    Show quick reference guide: QuickRef
    Exchange team blog: Get-ExBlog
    Show full output for a command: <command> | Format-List

    Tip of the day #33:

    Want to create a group of test users in your lab? Use this command:

     1..100 | ForEach { Net User "User$_" MyPassword=01 /ADD /Domain; Enable-Mailbox "User$_" }

    VERBOSE: Connecting to e2010.contoso.lan
    [e2010.contoso.lan] Processing data from remote server failed with the following error message: The type initializer f
    r 'Microsoft.Exchange.Configuration.Authorization.InitialSessionStateBuilder' threw an exception. For more information
     see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    VERBOSE: Connecting to E2010.contoso.lan
    [e2010.contoso.lan] Processing data from remote server failed with the following error message: The type initializer f
    r 'Microsoft.Exchange.Configuration.Authorization.InitialSessionStateBuilder' threw an exception. For more information
     see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    VERBOSE: Connecting to E2010.contoso.lan
    [e2010.contoso.lan] Processing data from remote server failed with the following error message: The type initializer f
    r 'Microsoft.Exchange.Configuration.Authorization.InitialSessionStateBuilder' threw an exception. For more information
     see the about_Remote_Troubleshooting Help topic.
        + CategoryInfo          : OpenError: (System.Manageme....RemoteRunspace:RemoteRunspace) [], PSRemotingTransportExc
       eption
        + FullyQualifiedErrorId : PSSessionOpenFailed
    Failed to connect to an Exchange server in the current site.
    Enter the server FQDN where you want to connect.:


    "When you hit a wrong note it's the next note that makes it good or bad". Miles Davis
    • Edited by pob579 Wednesday, October 5, 2011 9:27 PM
    • Proposed as answer by Terence Yu Thursday, October 6, 2011 3:01 AM
    • Marked as answer by Terence Yu Tuesday, October 11, 2011 5:49 AM
    Wednesday, October 5, 2011 8:55 PM