locked
Exchange 2013 Unified Messaging Transition from Exchange 2010 with Lync 2013 not working RRS feed

  • Question

  • Dear Team,

    I'm in middle of transitioning from Exchange 2010 to 2013. Currently we have the following setup:

    2x Exchange 2010 SP3 HUB/CAS (WNLB, CAS array)
    3x Exchange 2010 SP3 Mailbox DAG with (2 in Primary and 1 in DR site)
    1x Exchange 2010 SP3 UM
    Lync Server 2013

     


    2x Exchange 2013 CU2 Client Access (WNLB) Ex2013CAS01 and Ex2013CAS02
    3x Exchange 2013 CU2 Mailbox DAG Ex2013MB01, Ex2013MB02 and Ex2013MB03-DR (2 in Primary and 1 in DR site)

    • I have added Existing DialPlan to all the Exchange 2013 servers and Set the startup mode to TLS. Assigned internal CA certificate and enabled UM service in Exchange 2013 CAS and Mailbox servers.
    • Added the same certificate to the Lync 2013 server.
    • Moved the Exchange 2010 system mailbox
    • Disabled the 2010 Unified Messaging Server via Exchange 2010 EMC

    After restarting the Lync 2013 FE server, it gives errors saying unable to find UM Server, Cannot connect to server Ex2013MB01 and Ex2013MB02 with port 5061. Lync Missed call notification email not working.

    But when I check the Ex2013 Mailbox servers UM properties, it configured only to listen on port 5063. Port 5061 configured on CAS servers only.

    When I get the details of get-UMDialplan it shows only the Mailbox servers under UMServers.

     

    Did I miss any configuration? Is there are any proper documentation/guide when transitioning the UM services with Lync 2013?

     

    Below are the actual error in Lync 2013 FE logs:

    Error1

    Source: LS Exchange Unified Messaging Routing

    EventID: 44022

    Level: Error

    Description:

     

    An attempt to route to an Exchange UM server failed.

    The attempt failed with response code 504: Ex2013MB01.domain.local.

    Request Target: [LYNC_DIAL_PLAN@Ex2013MB01.domain.local], Call Id: [48d75515-ad99-40ae-be62-0074e9011dcf].

    Failure occurrences: 1, since 8/21/2013 11:12:00 PM.

    Cause: An attempt to route to an Exchange UM server failed because the UM server was unable to process the request or did not respond within the allotted time.

    Resolution:

    Check this server is correctly configured to point to the appropriate Exchange UM server. Also check whether the Exchange UM server is up and whether it in turn is also properly configured.

     

    Error2

    Source: LS Inbound Routing

    EventID: 45024

    Level: Error

    Description:

     

    Missed call notifications cannot be sent.

    An attempt to use an Exchange UM Server for a missed call notification failed: Ex2013MB01.domain.local

    Failure occurrences: 1, since 8/21/2013 11:12:03 PM.

    Failure Details: Failure occurred while connecting. Unable to establish a connection. No connection could be made because the target machine actively refused it 101.2.20.20:5061

    Cause: The Exchange UM server may be experiencing a problem.

    Resolution:

    Examine the event logs on the indicated Exchange UM server to determine the cause of the problem.

     

    Best Regards,

    R.Thenuwara

    Tuesday, August 27, 2013 10:56 AM

All replies

  • Did you assign the umipgateway and UMIProuter to all UM Server?

    regards Holger Technical Specialist UC

    Wednesday, September 11, 2013 10:25 PM
  • Hello

    you Need to do several Things for Integration lync with Exchange unified Messaging.

    Exchange topic

    1. Create UM Dialplan.
    2. Set the UMService
    3. Bind certificate to the UM service
    4. Set UCcallrouter (CAS Server) this is the UM Proxy Server
    5. Bind certificate to the UM Call Router Service
    6. Set new Default mail policy
    7. execute exchutil.ps1 script
    8. execute ocsumutil and configure SA and AA if needed
    9. Enbale User Voicemail

    cheers

    Octavian

    Preview Configuration example
    http://blogs.technet.com/b/nexthop/archive/2012/07/27/3509623.aspx



    Monday, September 23, 2013 11:39 AM