none
Duration calculation RRS feed

  • Question

  • I encountered a few strange issues regarding automatic calculation of duration.

    My task is of type Fixed Work, for example set as 4 hours to start on January 6th 2014. Orginially I had small percentage of resource usage, but even when I increase that to 20% the duration stays at 198,5 hours. I get an alert on the task and I can choose to change the duration... which I accept - but no changes are made to the duration!

    If I assign to another resource the duration is calculated to 20 hours (correctly) but the finish date remains as if the duration is still (almost) 200 hours.

    Perhaps the problem is related to the same resource being allocated to multiple projects... but the resource in question is not overloaded. At least I cannot recreate this for a single project.

    The workaround I use is to set a dummy resource and change the finish date manually.

    Best wishes,

    Valgarður Guðjónsson

    Monday, January 6, 2014 3:08 PM

All replies

  • Hi Valgarður Guðjónsson,

    I'll try to reproduce this behavior.

    What was the original % unit on the 4hrs duration task, before increasing it to 20%?


    Guillaume Rouyre - MBA, MCP, MCTS

    Monday, January 6, 2014 3:30 PM
    Moderator
  • What release of Project?  What service packs or cumulative updates do you have installed?

    I am assuming you have the task as an automatic scheduled - not manually scheduled?

    Monday, January 6, 2014 4:16 PM
    Moderator
  • Since you have mentioned the task is Fixed Work, then the task should be auto-scheduled only - Task type will be disabled for manually scheduled tasks.

    I think the issue should be in one of the two:

    1. Resource calendar: Check the working time of the resource in Resource Sheet. Is the working time 8 hours per day? If not, please change it through Work weeks tab

    2. Constraints: Check if you have any Finish-Later-Than or Must-Finish-On constraint for the task.

    If you could let us know the version of Project and screenshot of the schedule before and after assigning the resource, it can help to find the cause of the problem.


    Sai PMI-SP, MCTS Project

    Tuesday, January 7, 2014 4:43 AM
    Moderator
  • Just a quick note - if the task was originally auto scheduled and set to Fixed Work, it can be changed back to manually scheduled (retaining the fixed work setting) and the issue reproduces exactly as the OP notes.
    Tuesday, January 7, 2014 2:24 PM
    Moderator
  • Hi Julie - I tried as you indicated but unable to reproduce the issue. Any ideas

    Sai PMI-SP, MCTS Project

    Tuesday, January 7, 2014 4:32 PM
    Moderator
  • Hi Sai,

    One task - autoscheduled, Fixed Work.  Assign one resource at 10% assignment unit and 4 hours of work.  Project will calculate Duration = 5 days.

    In the task form, check "manually scheduled" and click OK.  The task is now manually scheduled, but still shows as Fixed Work (and Effort driven) in the Task Form.  Increase the assignment units and Project recalculates the work.  Duration is unchanged at 5 days - work increases.

    Drop the assignment units back to 10% - work decreases.  Add another resource - even though the task still appears effort driven (and fixed work) because the task is manually scheduled, it merely calculates the work for the additional resource.

    Tuesday, January 7, 2014 5:22 PM
    Moderator
  • Thanks and this is what I meant. Task type is neglected for Manually scheduled tasks. During resource assignment, the duration and dates will not be adjusted but only the work will.

    Sai PMI-SP, MCTS Project

    Tuesday, January 7, 2014 5:26 PM
    Moderator
  • Yes.  That is why I asked for confirmation that he was using autoscheduled tasks.
    Tuesday, January 7, 2014 6:10 PM
    Moderator
  • :) I am watching this thread to see what solves Valgarður Guðjónsson issue.

    Sai PMI-SP, MCTS Project

    Wednesday, January 8, 2014 2:06 AM
    Moderator
  • Thanks, (didn't get notification on replies)

    I believe it was 4% or 5% - as in this happens with complex projects and shared resources. I haven't been able to reproduce this in a small single project.

    However, a constant problem...

    Wednesday, February 19, 2014 4:54 PM
  • Project 2013, (15.0.4551.1007) 64-bit - not sure of service packs, I see no information..
    Wednesday, February 19, 2014 5:00 PM
  • Thanks, this is auto-scheduled, and 8 hours per day - although I would expect any other valid hours per day to work as well.

    There are no constraints.. but I don't believe a screenshot will help, it is complex (well, not very simple) project with shared resources.

    Wednesday, February 19, 2014 5:03 PM
  • Apologies for a late reply - I didn't get any notificaitons, so I thought there were no answers... have been adjusting manually for a few weeks.

    Originally the tasks were manual (I keep trying to change the default without success) but I changed to automatic.

    My feeling (but only a "feeling") now is that multiple projects using shared resources is the problem - at least I haven't been able to reproduce in a small project.


    Wednesday, February 19, 2014 5:08 PM
  • Project does recognize that I have made changes and asks whether I want to decrease / increase duration or change the amount of work. But ignores my selection.
    Wednesday, February 19, 2014 5:12 PM
  • I don't see any updates for Project 2013 - only older versions and servers.. am I missing something obvious?
    Wednesday, February 19, 2014 5:15 PM
  • If I take a project and try to remove resource sharing.. at first Project crashes... but then seems to calculate fine.

    Resource sharing between projects is very important though...

    Wednesday, February 19, 2014 5:19 PM
  • Originally the tasks were manual (I keep trying to change the default without success) but I changed to automatic.

    There are 4 ways in MS Project 2013 to set tasks to autoscheduled:

    • in the file/option menu, schedule section, for all new projects or current project

    • In the status bar for the current project for new tasks:

    • With the "mode" column for each task
    • With the manually schedule button in the task tab of the ribbon for each task

    Note that if you're using Project Server, the administrator can prevent in the server settings\Operational Policies users from changing the default scheduling mode.

    Hope this helps.


    Guillaume Rouyre - MBA, MCP, MCTS

    Wednesday, February 19, 2014 5:53 PM
    Moderator
  • See below for the list of updates for the Office 2013 products.  Project 2013 most recent cumulative update is December 2013.


    http://technet.microsoft.com/en-us/office/ee748587
    Wednesday, February 19, 2014 6:17 PM
    Moderator
  • Is your calculation after each project on or off?  Please check File > Options, Schedule.

    Wednesday, February 19, 2014 6:20 PM
    Moderator
  • Thanks, but like I said I have tried, it just falls back to manual! No, I am not using Project Server.. but this is a minor issue..
    Wednesday, February 19, 2014 10:37 PM
  • Thanks, according to Programs and Features in the control panel the latest Project Update is from January 15th, 2014.
    Wednesday, February 19, 2014 10:45 PM
  • Thanks, but yes, - of course - although sometimes I do miss something as simple :)

    Most of the time it recalculates fine.

    Wednesday, February 19, 2014 10:48 PM