locked
"Storage Space protective partition" cannot remove RRS feed

  • Question

  • Dear Sir,

    With Windows Server 2016 Datacenter edition, I've configured storage space direct (S2D) and it works on 3 x server (1 + 3 HDD per server).

    For some reasons, I want to re-install the OS. What I did is to re-install the OS HDD but forget to do something on S2D HDD (3 x HDD) before re-installing the OS. When OS is installed completely, I found those 3 x HDD is treated "offline". I saw the partition is with "Storage Space protective partition" marked in Computer Management - Disk Management.

    Test I.

    =========================================

    I've tried below in PowerShell with administrator privilege

    diskpart

    list disk

    select disk <number>

    clean

    But got the message "diskpart has encountered an error access is denied".

    I can saw "*" mark in GPT field when list disk with diskpart. The status is offline.

    But cannot make them on-line with diskpart command.

    Test II.

    =======================================

    It is not work either go through Disk Management GUI. It responsed ""virtual disk manager" "access is denied" if I right-click them and select "Online"

    It seems the previously S2D settings is still remained in those HDD so that they cannot be on-lined or do anything on them.

    Do you have any idea? How to clear the previously setting on those HDD?

    Regards,

    cc2010

    Wednesday, February 15, 2017 7:31 AM

All replies

  • I use Gparted and nuke the hidden s2d partitions like that. after deleting the partitions, make sure you hit the apply button otherwise nothing gets removed.

    MS have a 'clean disks' script here

    https://technet.microsoft.com/windows-server-docs/storage/storage-spaces/hyper-converged-solution-using-storage-spaces-direct#step-34-clean-disks

    But when I tried it, it didn't clean my mechanical HDs properly, only the S2D SSDs

    Thursday, February 16, 2017 10:29 PM
  • Thanks for the reply, I'll try it.
    Friday, February 17, 2017 7:15 AM