locked
Error (0x80040222) and 0x8000ffff RRS feed

  • Question

  • I am working on trusted domains and client in the remote domain get the following errors:

    Error initializing client registration (0x80040222) and RegTask: Failed to refresh site code. Error: 0x8000ffff. Clients are behind router and the ports are open, we can do a packet trace from the client to the MP at both ports 80 and 443. What else can we look at? this is a mixed mode site.

    Monday, November 8, 2010 8:15 PM

Answers

  • Hi Amnon,

    It seemed that the problem is caused by incorrect specified client installation properties.

    Issue: When you install a Configuration Manager client on a target machine, it may fail to register and as a result it's unable to pull the machine policies.  You may also notice errors similar to the following in the ClientIDManagerStartup.log:

    Error initializing client registration
    (0x80040222). ClientIDManagerStartup 1/8/2009 1:12:10 PM 1896 (0x0768)
    RegTask: Failed to refresh site code. Error:
    0x80004005 ClientIDManagerStartup 1/8/2009 12:51:41 PM 1896 (0x0768)

    Cause: This can happen due to incorrectly specified client installation properties.  For example, let's say you defined the client installation properties as:

    SMSSITECODE=ABC,SMSCACHESIZE=1000

    ConfigMgr does not validate the site code to verify that it should be limited to only 3-4 characters so since there's a comma but no space, anything specified after SMSSITECODE= is considered to be the site code. As a result, the installation command line becomes something like the following:

    MSI PROPERTIES are REINSTALL=ALL REINSTALLMODE=vmaus INSTALL="ALL"
    SMSSITECODE="ABC,SMSCACHESIZE=1000" CCMHTTPPORT="80" CCMHTTPSPORT="443"
    CCMHTTPSSTATE="0" CCMFIRSTCERT="0"
    SMSPUBLICROOTKEY=<...key...>

    Note that the SMSSITECODE is considered as "ABC,SMSCACHESIZE=1000" and the installation will actually proceed without any errors. However, this incorrect value is also stored in the registry and as a result the client is never able to successfully register.

    Resolution: To resolve this issue we changed the client installation properties and removed the comma as follows:

    SMSSITECODE=ABC SMSCACHESIZE=1000

    After re-pushing the client, it showed the command line MSI Properties as follows:

    MSI PROPERTIES are REINSTALL=ALL REINSTALLMODE=vmaus INSTALL="ALL"
    SMSSITECODE="ABC" SMSCACHESIZE="1000" CCMHTTPPORT="80" CCMHTTPSPORT="443"
    CCMHTTPSSTATE="0" CCMFIRSTCERT="0"
    SMSPUBLICROOTKEY=<...key...>

    After doing this the client was successfully installed, it successfully registered and was able to pull the policies from the Site Server.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Eric Zhang CHN Friday, November 19, 2010 8:34 AM
    Wednesday, November 10, 2010 7:29 AM

All replies

  • Are these new client installs?

    How are the clients being installed; e.g., client push, manual via command line, WSUS, other?

    Are the clients using NAT to get to the site server?

     

     


    Jason | http://myitforum.com/cs2/blogs/jsandys | http://blogs.catapultsystems.com/jsandys/default.aspx | Twitter @JasonSandys
    Monday, November 8, 2010 8:30 PM
  • Hi,

    Can you share the commandline you used to install the clients?


    Kent Agerlund | http://scug.dk/ | The Danish community for System Center products
    Monday, November 8, 2010 10:44 PM
  • Hi Amnon,

    It seemed that the problem is caused by incorrect specified client installation properties.

    Issue: When you install a Configuration Manager client on a target machine, it may fail to register and as a result it's unable to pull the machine policies.  You may also notice errors similar to the following in the ClientIDManagerStartup.log:

    Error initializing client registration
    (0x80040222). ClientIDManagerStartup 1/8/2009 1:12:10 PM 1896 (0x0768)
    RegTask: Failed to refresh site code. Error:
    0x80004005 ClientIDManagerStartup 1/8/2009 12:51:41 PM 1896 (0x0768)

    Cause: This can happen due to incorrectly specified client installation properties.  For example, let's say you defined the client installation properties as:

    SMSSITECODE=ABC,SMSCACHESIZE=1000

    ConfigMgr does not validate the site code to verify that it should be limited to only 3-4 characters so since there's a comma but no space, anything specified after SMSSITECODE= is considered to be the site code. As a result, the installation command line becomes something like the following:

    MSI PROPERTIES are REINSTALL=ALL REINSTALLMODE=vmaus INSTALL="ALL"
    SMSSITECODE="ABC,SMSCACHESIZE=1000" CCMHTTPPORT="80" CCMHTTPSPORT="443"
    CCMHTTPSSTATE="0" CCMFIRSTCERT="0"
    SMSPUBLICROOTKEY=<...key...>

    Note that the SMSSITECODE is considered as "ABC,SMSCACHESIZE=1000" and the installation will actually proceed without any errors. However, this incorrect value is also stored in the registry and as a result the client is never able to successfully register.

    Resolution: To resolve this issue we changed the client installation properties and removed the comma as follows:

    SMSSITECODE=ABC SMSCACHESIZE=1000

    After re-pushing the client, it showed the command line MSI Properties as follows:

    MSI PROPERTIES are REINSTALL=ALL REINSTALLMODE=vmaus INSTALL="ALL"
    SMSSITECODE="ABC" SMSCACHESIZE="1000" CCMHTTPPORT="80" CCMHTTPSPORT="443"
    CCMHTTPSSTATE="0" CCMFIRSTCERT="0"
    SMSPUBLICROOTKEY=<...key...>

    After doing this the client was successfully installed, it successfully registered and was able to pull the policies from the Site Server.

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Eric Zhang CHN Friday, November 19, 2010 8:34 AM
    Wednesday, November 10, 2010 7:29 AM