locked
DNS, DHCP, IPV6 RRS feed

  • Question

  • Hi,

     I have a server network with no dhcp. I assign ipv4 addresses manually. I have IPV6 enabled and servers get IPV6 addressess,

      but IPV6 addressess are not registered in DNS, even though the NIC is configured to do so.

     I am wondering what I am missing. Do I need to create a DHCP scope or IPV6 to get IPV6 registered in dns.?

     Can I check if the switches and routers are IPV6 enabled? what I have in mind is service like direct access it uses IPV6.

     thanks.

     


    Erro

    Friday, January 1, 2016 10:35 PM

Answers

  • Hi Erro,

    First thing to notice is that we can't register link-local IPv6 address in DNS server.

    So, what is the type of the IPv6 address, link-local, site-link, or global IPv6 address? How did you get the IPv6 address, manually configured or obtained from DHCP server.

    Then check if command ipconfig/registerdns could help.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Erró Monday, March 21, 2016 12:20 PM
    Monday, January 4, 2016 2:53 AM

All replies

  • Hi Erro,

    First thing to notice is that we can't register link-local IPv6 address in DNS server.

    So, what is the type of the IPv6 address, link-local, site-link, or global IPv6 address? How did you get the IPv6 address, manually configured or obtained from DHCP server.

    Then check if command ipconfig/registerdns could help.

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    • Marked as answer by Erró Monday, March 21, 2016 12:20 PM
    Monday, January 4, 2016 2:53 AM
  •  Hi Anne and thanks for your reply,

      The IPV6 address are automaticly applied, i.e. IPV6 is endabled and IPV6 ip address is applied global I think.

       There is no DHCP for IPV6. I have tried ipconfig/registerdns many times but it does not work.

       Here is how ipconfig /all looks on this server, which is a domain controller  running dns, 


    C:\Windows\system32>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : blabla-ADDS-A
       Primary Dns Suffix  . . . . . . . : blabla.net
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : esvagt.net

    Ethernet adapter Ethernet:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft Hyper-V Network Adapter #2
       Physical Address. . . . . . . . . : 00-1D-D8-B7-1C-03
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::481c:2fd8:4109:4215%16(Preferred)
       IPv4 Address. . . . . . . . . . . : 10.20.150.50(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 10.20.150.1
       DHCPv6 IAID . . . . . . . . . . . : 318774744
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1B-A3-B2-D2-00-1D-D8-B7-1C-57

       DNS Servers . . . . . . . . . . . : 127.0.0.1
                                           10.20.150.51
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{8690C106-31BB-4442-BA06-1C08BF987F8E}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    This is a ipconfig/all on a member server running Direct Access, which I am trying to configure whit little luck because of IPV6 errors or misunderstanding. I do sometimes get error in event logs when I do registerdns??


    C:\Windows\system32>ipconfig /all

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : blablas-diac-a
       Primary Dns Suffix  . . . . . . . : blabla.net
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : No
       WINS Proxy Enabled. . . . . . . . : No
       DNS Suffix Search List. . . . . . : esvagt.net

    Ethernet adapter Ethernet0:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Intel(R) 82574L Gigabit Network Connectio
    n
       Physical Address. . . . . . . . . : 00-50-56-97-6B-FA
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::a0e5:94ca:c75:cde%15(Preferred)
       IPv4 Address. . . . . . . . . . . : 10.20.150.125(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Default Gateway . . . . . . . . . : 10.20.150.1
       DHCPv6 IAID . . . . . . . . . . . : 402673750
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-7F-3C-FA-00-50-56-97-6B-FA

       DNS Servers . . . . . . . . . . . : 10.20.150.50
                                           10.20.150.51
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{AE084692-6F4C-4397-99C0-CC10C47FC492}:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : fd78:d478:29ff:1:0:5efe:10.20.150.125(Pre
    ferred)
       Link-local IPv6 Address . . . . . : fe80::5efe:10.20.150.125%12(Preferred)
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 218103808
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-7F-3C-FA-00-50-56-97-6B-FA

       DNS Servers . . . . . . . . . . . : 10.20.150.50
                                           10.20.150.51
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter 6TO4 Adapter:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter IPHTTPSInterface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : IPHTTPSInterface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : fd78:d478:29ff:1000::1(Preferred)
       IPv6 Address. . . . . . . . . . . : fd78:d478:29ff:1000::2(Preferred)
       IPv6 Address. . . . . . . . . . . : fd78:d478:29ff:1000:18b7:7c5a:5820:873(Pr
    eferred)
       Link-local IPv6 Address . . . . . : fe80::18b7:7c5a:5820:873%16(Preferred)
       Default Gateway . . . . . . . . . :
       DHCPv6 IAID . . . . . . . . . . . : 419430400
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1D-7F-3C-FA-00-50-56-97-6B-FA

       NetBIOS over Tcpip. . . . . . . . : Disabled

      If i do on this member server ipconfig /registerdns  i get this in eventlog

     

    The system failed to register pointer (PTR) resource records (RRs) for network adapter

    with settings:

               Adapter Name : {5AEB59A8-2986-45DD-AB2E-DDB7C0C3F457}

               Host Name : blabla-diac-a

               Adapter-specific Domain Suffix : blabla.net

               DNS server list :

                 10.20.150.50, 10.20.150.51

               Sent update to server : <?>

               IP Address :

                 fd78:d478:29ff:1:0:5efe:10.20.150.125

    The reason the system could not register these RRs during the update request was because of a system problem. You can manually retry DNS registration of the network adapter and its settings by typing 'ipconfig /registerdns' at the command prompt. If problems still persist, contact your DNS server or network systems administrator. See event details for specific error code information.


    Erro


    • Edited by Erró Monday, January 4, 2016 7:07 AM
    Monday, January 4, 2016 6:52 AM
  • Hi,

     if IPV6 address has been assigned tol the server global, should I  not be able to do ipconfig/registerdns

     without getting errors?


    Erro

    Tuesday, January 5, 2016 8:17 PM
  • Hi Erro,

    Since I'm a little confused about your question, so check if my understanding is correct.

    The client" blablas-diac-a" has problem register its IPv6 address on DNS, it is a DirectAccess client, and it gets IPv6 address from DirectAccess server. When you run ipconfig/registerdns you get error "The system failed to register pointer (PTR) resource records (RRs) for network adapter".

    If so, this error may due to you do not have reserve IPv6 lookup zone on DNS.

    By the way, could you register AAAA record on Forward lookup zone?

    Best Regards,

    Anne


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Friday, January 8, 2016 8:48 AM
  •   Hi Anne,

       the problem seeems to be that for some reason I cannot register IPV6 in dns. There are som IPV6    registerd there. All IPV6 ip are are received automatically and not by dhcp. All servers have IPV6 addresses

      but they are not registered in DNS. I can manually register IPV6  AAAA record in dns, but I can not ping them, maybe I am not doing it correct? I am not using reverse lookup zones.

     I have no reconfigured Direct Access on a new server but still have the same problem.

     

     


    Erro

    Monday, January 11, 2016 7:57 AM