locked
sfc "repairs" same corrupt file usbhub.sys.mui over and over RRS feed

  • Question

  • Running the system file checker I get lines like this in the cbs.log file:

    2016-02-25 10:39:25, Info                  CSI    00000200 [SR] Repairing corrupted file [ml:520{260},l:74{37}]"\??\C:\Windows\system32\drivers\en-US"\[l:28{14}]"usbhub.sys.mui" from store

    The same line appears two or three times, with different time stamps, each time I run sfc.  So apparently the file is either not really corrupt or it is not being repaired properly.  However, I think it might be the cause of my system becoming unresponsive - which it always eventually does.  My hard drive was reimaged (by Dell) in September, which is the date shown for the file.

    How can I repair it?

    thanks,

    Daren

    Saturday, February 27, 2016 8:04 PM

All replies

  • D@P

    I suspect that the corrupt file is not the cause of you issues.  Can you be more specific about them?


    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    Saturday, February 27, 2016 8:07 PM
  • Well, for example, the moment I saw your reply and tried to read it, Firefox became unresponsive.  I couldn't close other windows either, nor logoff or shut down the computer (Dell Precision M4700 laptop).  I ended up shutting the computer off manually.

    This happens at seemingly random times and is not associated with any specific application.  It can be minutes or hours after startup.  Sometimes I try shutting down and it seems to comply, but then never finishes.  It has also happened that I couldn't log on without turning the system off and trying again.  In any case the system always becomes unresponsive eventually unless we succeed in shutting down.

    Hardware scans do not reveal any problems, nor do any of Dell's diagnostic tests.  Registry cleanup, such as with CCleaner, do not help.  Dell replaced the HD in Sept and we've had the problem since not long after.  I've been running diagnostics off and on since hoping to have something specific to report to Dell support.  I finally gave up and contacted them this week and am still conferring with them.

    I did see somewhere that problems with usbhub.sys.mui can causes systems to become unresponsive, but I know nothing definite.

    Saturday, February 27, 2016 8:31 PM
  • I should mention also that our virus software, Norton 360, is up-to-date and has found nothing that would be the cause.  Startup programs all look legitimate - there aren't even very many.  However, I'm no expert in determining what startup program or "service" might be affecting the system.
    Saturday, February 27, 2016 8:45 PM
  • Whats the underlying issue that prompted you to run SFC?

    Wanikiya and Dyami--Team Zigzag Windows IT-PRO (MS-MVP)

    Sunday, February 28, 2016 2:40 AM
  • The laptop always lapsing into nonresponsiveness, as described above.  I hadn't known about SFC before this week.

    When I first ran it two days ago, it found and "repaired" the file usbhub.sys.mui, after which I watched the system to see if anything had changed.  When it was apparent that the problem persisted I ran SFC again only to learn it was "repairing" the same file!  Same thing after several more tries.  Hence I came to this forum to see what is known about that.


    Sunday, February 28, 2016 3:12 AM
  • Hi dcline.at.punkuter,

     

    When you mentioned “system becoming unresponsive”, is your system crashing, stopping working? Or you cannot communicate with your system with USB devices (like mouse)?

     

    From my experiences, the usbhub.sys.mui file might be related to USB drivers, we could try to update the USB drivers to have a test.

    We could try to uninstall the USB [Universal Serial bus] host controller’s driver and all related USB drivers from Device Manger, then restart and re-install them again.

    Since the SFC command did not worked for you, we could perform a system restore to recover the machine to a previous normal point if it is possible.

     

    In addition, I notice that you have already contacted the DELL support, if there is any results, please let us know.

     

    Best regards.


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Monday, February 29, 2016 10:25 AM
  • Not "crashing" per se.  Just becomes very sluggish or not responding.  Nothing to do with USB devices - there need not be any.  Which isn't to say you aren't correct that usbhub.sys.mui has something to do with them - the file's name certainly suggests it does.  But I can't say we have any USB port problems.

    Windows updates regularly as does Dell, and both check for drivers.

    My question here originally was how or whether to repair that file if SFC thinks it's a problem but doesn't actually fix it.  For example, where to get the latest version that is known to be problem-free, or at least not corrupt?  Admittedly, that's not my main problem, but it is what I came here for. 

    Of course, I appreciate all suggestions for dealing with the laptop's nonresponsiveness, as well. :)

    thanks,

    D


    Tuesday, March 1, 2016 4:57 AM
  • Hi dcline.at.punkuter,

     

    Have you tried the manually steps in SFC article?

    We could refer to this link manually to replace a corrupted system file with a known good copy of the file.

    https://support.microsoft.com/en-us/kb/929833

     

    Good Luck


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.


    Wednesday, March 2, 2016 10:06 AM
  • I did see that earlier.  It brought me here hoping I'd learn where to find the most recent reliable version. :)

    Dell is asking me to reinstall Windows.  So I'll do that, watch the system, and then try SFC again to see if it thinks there's a problem.  It may be a day or two; I'll let you know how it goes ...

    Wednesday, March 2, 2016 10:57 PM
  • Reinstalling Windows from the disk that came with the system (just 2 years ago) isn't as easy as it sounds!  Had to get some dozen drivers from Dell, including for internet.  After installation, I needed .Net Framework 4.0, and Windows Update found some 250 updates to install.  Hours and hours it took.

    I mention this because maybe Microsoft could take a hint and find a way to make this a little more automatic and painless with their install setup wizard ...

    Anyway, SFC shows no sign of a corrupted file now, and our main issue seems to be solved as well.  I guess I'll never know whether they were related problems.

    D

    Saturday, March 5, 2016 4:30 PM
  • Hi dcline.at.punkuter

     

    It is glad that to hear that you have solved this issue by clean install. If SFC shows no sign of a corrupted file now, it is suggested to manually create a restore point. So we will be able to execute a system restore, restore your system to this healthy state if some similar issues happened again.

     

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, March 8, 2016 1:49 AM
  • Yes, I did do that first thing.  Thanks for the reminder.

    dcline.at.punkuter

    Thursday, March 10, 2016 1:38 PM