locked
Microsoft 6to4 Adapter Error Code31 RRS feed

  • Question

  • I get disconnected while I'm surfing the net. When this happen,on notification area,where normally two computers with a globe are,the globe changes to yellow ! and it says limited connectivity. When I did diagnose test it said that there might be a problem with my network adapter(s). And when I tried to turn off my computer,the screen went black,but I could hear that the computer was still working,and after about 5minutes 'Blue Screen Error' showed up. And like this every time,when I get disconnected. The only thing that I can do is,restarting.When I restart my computer 'Blue Screen Error' does not show up. I went to Device Manager and found that under Network Adapters Microsoft 6to4 Adapters say: "This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)". And one last thing,that I think is important is that when I get disconnected,and I unplug the Ethernet cable from Ethernet port,the green light that is there does not turns off(normally when I unplug the cable,the green light turns off because the Ethernet cable is not connected). I have Windows Vista if that helps. Please help me.
    Thursday, March 26, 2009 10:41 PM

Answers

  • Hi,

     

    Based on my research, the Microsoft 6to4 Adapter actually is a virtual device which does some conversions between IPv6 and IPv4. Regarding the issue, please also refer to the following Knowledge Base:

     

    http://support.microsoft.com/kb/932520

     

    Therefore, we can just safely ignore this issue and this may be not related to the connectivity issue.

     

    Regarding the network connectivity issue, please remove and reinstall the NIC driver to see if it works. (If there is a new version of driver released, please also try it.)

     

    With regard to this Blue Screen issue, we generally need to analyze the performance monitor logs and memory dump files to locate the root cause. Unfortunately, debugging is beyond what we can do in the forum because of the nature of forum support. I'd like to recommend that you contact Microsoft Customer Support Service (CSS) for assistance so that this problem can be resolved efficiently. To obtain the phone numbers for specific technology request please take a look at the web site listed below:

    http://support.microsoft.com/default.aspx?scid=fh;EN-US;PHONENUMBERS

     

    If you are outside the US please see http://support.microsoft.com for regional support phone numbers.

     

    I hope the problem will be resolved soon. Thanks.

     


    Nicholas Li - MSFT
    Monday, March 30, 2009 3:39 AM
    Moderator