locked
How to setup FPE content filter to make Outlook blocked senders lists to work correctly? RRS feed

  • Question

  • Hi,

    I have Exchange 2010 EDGE server with The Forefront Protection 2010 for Exchange Server (FPE). All messages coming through FPE content filter receive SCL:-1 and that means Outlook Blocked Senders Lists are not applied on them.

    I found this in FPE documentation:
    Configuring content filtering
    ...
    FPE does not assign SCL ratings between SCL: 1 to SCL: 4. Messages that fall into this category are assigned SCL ratings of SCL:-1 or SCL: 0.
    http://technet.microsoft.com/en-us/library/dd639396.aspx

    But I see only SCL:-1, not a single SCL:0 mail. That does not make sense to me. I don't understand why to shoot yourself in the foot and provide only 2 values (-1; 0) instead of 6 values [-1;0;1;2;3;4]? 

    How are the Outlook blocked senders list supposed to work if all emails receive -1 and not 0? How can users block senders from unwanted newsletters, too chatty senders or other sources that are not general mass spam but just something they don't want to have in their inbox?

    Thursday, March 3, 2011 9:20 AM

Answers

  • I found it

    [PS] > New-FseExtendedOption –Name CFAllowBlockedSenders –Value true

     

    [PS] > Get-FseExtendedOption –Name CFAllowBlockedSenders

    Name                                                        Value

    ----                                                        -----

    CFAllowBlockedSenders                                       true

    after services restart messages receive SCL: 0 instead of -1 and blocking senders in Outlook starts to work. I suggest this should be documented in official Technet documentation.

    Thursday, March 3, 2011 11:31 AM

All replies

  • I found it

    [PS] > New-FseExtendedOption –Name CFAllowBlockedSenders –Value true

     

    [PS] > Get-FseExtendedOption –Name CFAllowBlockedSenders

    Name                                                        Value

    ----                                                        -----

    CFAllowBlockedSenders                                       true

    after services restart messages receive SCL: 0 instead of -1 and blocking senders in Outlook starts to work. I suggest this should be documented in official Technet documentation.

    Thursday, March 3, 2011 11:31 AM
  • i tried this command in exchange 2010 ps but it did not work
    Tuesday, July 17, 2012 6:24 AM
  • Hi,

    you need to run it in the Forefront Managementshell.

    Greetings

    Christian


    Christian Groebner MVP Forefront

    • Proposed as answer by MAHER0 Tuesday, July 17, 2012 7:48 AM
    Tuesday, July 17, 2012 6:46 AM
  • thanks

    i ran it, i have ForeFront installed on 4 exchange servers - do i have to run on all

    and what services should i restart ?

    Tuesday, July 17, 2012 7:20 AM
  • Hi,

    yes you have to run it on all servers. Normaly it should be enough to restart the transport service.

    Greetings

    Christian


    Christian Groebner MVP Forefront

    Tuesday, July 17, 2012 7:39 AM
  • thank you so much

    i ran it on all and i restarted the Microsoft Forefront Server Protection Controller which restated the exchange transport service 

    regards

    • Proposed as answer by MAHER0 Tuesday, July 17, 2012 7:48 AM
    Tuesday, July 17, 2012 7:48 AM