none
User Addition in Project Server 2013 RRS feed

  • Question

  • Hi,

    I do not see Manage Users option in PWA 2013, please tell me how to add users in Project Server 2013


    K.Gokulraj

    Friday, September 27, 2013 6:02 AM

Answers

  • Hi,

    I assume you did not change permission mode after Installation. Default permission mode is Sharepoint, but you can switch to Project Server Permission mode (like Project Server 2010) and earlier by running

    Set-SPProjectPermissionMode [-Url] <Uri> [-Mode] <SharePoint | ProjectServer | UninitializedSharePoint | UninitializedProjectServer> [[-AdministratorAccount] <String>] [-AssignmentCollection <SPAssignmentCollection>]

    Switching security modes deletes all configured permissions for the specified Project Web App instance and applies the default settings for the specified mode. So think about carefully, especially when switching from Project Server mode to Shraepoint mode at a later time.

    With Project Server permission mode you will see Mange Users/groups/Categories as known from previous version.

    Does that help?
    Barbara

    Friday, September 27, 2013 6:56 AM
    Moderator

All replies

  • Hi,

    I assume you did not change permission mode after Installation. Default permission mode is Sharepoint, but you can switch to Project Server Permission mode (like Project Server 2010) and earlier by running

    Set-SPProjectPermissionMode [-Url] <Uri> [-Mode] <SharePoint | ProjectServer | UninitializedSharePoint | UninitializedProjectServer> [[-AdministratorAccount] <String>] [-AssignmentCollection <SPAssignmentCollection>]

    Switching security modes deletes all configured permissions for the specified Project Web App instance and applies the default settings for the specified mode. So think about carefully, especially when switching from Project Server mode to Shraepoint mode at a later time.

    With Project Server permission mode you will see Mange Users/groups/Categories as known from previous version.

    Does that help?
    Barbara

    Friday, September 27, 2013 6:56 AM
    Moderator
  • Hi Barbara,

    Thanks for your reply.

    My PWA url is http://prosrv-tr/PWA. And the administrator account name is "administrator".

    can you please send me what should i enter in the below code:

    Set-SPProjectPermissionMode [-Url] <Uri> [-Mode] <SharePoint | ProjectServer | UninitializedSharePoint | UninitializedProjectServer> [[-AdministratorAccount] <String>] [-AssignmentCollection <SPAssignmentCollection>]

    Also please let me know where should i enter these details( is it in sharepoint 2013 management shell?)

    Please help


    K.Gokulraj

    Friday, September 27, 2013 7:19 AM
  • Hi,

    here are samples: http://technet.microsoft.com/en-us/library/jj219486.aspx

    So in your case, it should be Set-SPPRojectPermissionMode –Url http://server/PWA -AdministratorAccount YourDomain\administrator -Mode ProjectServer

    Good luck!
    Barbara


    Friday, September 27, 2013 7:34 AM
    Moderator
  • Hi K --

    What is your administrator password?

    ;-)

    Good luck!

    -- tz


    Tony Zink | Vice President, EPMA | http://www.epmainc.com | Blog: http://www.epmablog.com | Training: http://www.epmainstitute.com

    Friday, September 27, 2013 8:36 PM
  • Hi Barbara,

    Thanks for your reply.

    I have done the following:

    Click Start - SharePoint 2013 Management Shell

    It shows PS c:\> ___________, here i entered: Set-SPPRojectPermissionMode –Url http://prosrv-tr/PWA -AdministratorAccount prosrv\administrator -Mode ProjectServer

    prosrv.com is my domain name(which i checked in my system- computer-properties)

    then i press enter, i do not see any error message.

    I opened PWA and click server settings, still i do not see Manager users options.

    Have i done correct? Do i need to restart my system?

    Please help.


    K.Gokulraj

    Saturday, September 28, 2013 6:05 AM
  • It is " pass@word1 "

    K.Gokulraj

    Saturday, September 28, 2013 6:06 AM
  • Hi Barbara,

    Good News, i got it.

    I checked using Get-SPProjectPermission mode and i closed and reopened it.

    Now it has come.

    Thanks for your help.


    K.Gokulraj

    Saturday, September 28, 2013 7:03 AM
  • That's fine.

    Success with 2013!

    Barbara

    Saturday, September 28, 2013 7:22 AM
    Moderator