locked
Cannot Print in IE11 on Terminal Server 2012 RRS feed

  • Question

  • I am having an issue with printing with IE11 in Terminal Server 2012.

    Issue-

    The print preview shows up as blank, and when I hit print, nothing happens(the print window never shows up). I can print from other applications fine. Additionally, this is only affecting one user on my terminal server. Everyone else is able to print out of Internet Explorer fine. I have tried launching IE with add-ons disabled and the problem exists in both 64/32 bit IE. I have rebooted my terminal server. The user is still unable to print from IE. I have checked that enhanced IE security is off.

    Nothing seems to be working here.

    Any suggestions?

    Thursday, July 31, 2014 2:25 PM

Answers

  • Hi,

    According to your description, this just occurs to particular user profile. Please check if there is a Low folder existed in following path:

    "%userprofile%\AppData\Local\Temp

    If it does exist, take these steps to apply the integrity level:

    1.Open a Command Prompt, and then click Run as administrator.

    2.Type following command and press ENTER:

    ICACLS "%userprofile%\AppData\Local\Temp\Low" /setintegritylevel (OI)(CI)low

    3.Restart the computer.

    4.Print or print preview a Web page in Internet Explorer.


    Alex Zhao
    TechNet Community Support

    • Marked as answer by Michael_LS Friday, August 8, 2014 10:56 AM
    Wednesday, August 6, 2014 6:05 AM

All replies

  • can print from other applications fine.

    See if the user can print to a virtual printer, XPS Document Writer, then print the resulting .xps file?

    Nothing seems to be working

    All the other usual workarounds involve changes in the level of security, e.g. setting Protect Mode off in various ways or even elevating the iexplore.exe task if necessary.  Have you tried those things too?



    Robert Aldwinckle
    ---

    Friday, August 1, 2014 12:17 PM
    Answerer
  • I'll test the xps printing, but to answer your other question, yes. I have tried turning off protected mode and printing a trusted site. Same issue. I have had this problem before in a terminal environment, but it went away on its own. Now it has returned!
    Friday, August 1, 2014 1:41 PM
  • Hi,

    According to your description, this just occurs to particular user profile. Please check if there is a Low folder existed in following path:

    "%userprofile%\AppData\Local\Temp

    If it does exist, take these steps to apply the integrity level:

    1.Open a Command Prompt, and then click Run as administrator.

    2.Type following command and press ENTER:

    ICACLS "%userprofile%\AppData\Local\Temp\Low" /setintegritylevel (OI)(CI)low

    3.Restart the computer.

    4.Print or print preview a Web page in Internet Explorer.


    Alex Zhao
    TechNet Community Support

    • Marked as answer by Michael_LS Friday, August 8, 2014 10:56 AM
    Wednesday, August 6, 2014 6:05 AM