none
Enable-Mailbox - Load balancing failed to find a valid mailbox database RRS feed

  • Question

  • Executing the command "Enable-Mailbox -Identity USER@DOMAIN.com -Alias USER" results in the error "Load balancing failed to find a valid mailbox database."

    I think I've performed most of the troubleshooting I've found on the internet and forums:

    • Specifying a database in the command allows it to succeed
    • Upgraded software version to Exchange Server 2010 SP3 RU16 ("Get-Command ExSetup | ForEach {$_.FileVersionInfo}" shows 14.03.0339.000 as the ProductVersion and FileVersion)
    • "Get-MailboxDatabase | ft Name, IsExcludedFromProvisioning, IsSuspendedFromProvisioning, Recovery" shows two databases with False for all columns

    I'm not sure as to the next steps for troubleshooting.  Any assistance or ideas would be greatly appreciated.  Thank you!

    - Andrew

    Tuesday, March 14, 2017 5:45 PM

All replies

  • Try setting both IsExcludedFromProvisioning and IsSuspendedFromProvisioning to $True and then back to $False.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Wednesday, March 15, 2017 3:26 AM
  • Hi,

    Run the following command to make sure database is mounted.

    Get-MailboxDatabase | Get-MailboxDatabaseCopyStatus

    I met the same error in an old thread, it was resolved by rebooting Exchange Server. You may try it in a down time.

    If you have multiple AD Sites, refer to this similar thread

    https://social.technet.microsoft.com/Forums/exchange/en-US/726a0d38-b92d-43dd-8993-761aac959b0b/load-balancing-failed-to-find-a-valid-mailbox-database?forum=exchange2010


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Lynn-Li Thursday, April 6, 2017 5:16 AM
    Wednesday, March 15, 2017 7:07 AM
  • Ah, the ol' "turn it off, turn it back on again" approach. I gave it a try and unfortunately it made no difference. Thank you for the suggestion!
    Thursday, March 16, 2017 3:19 PM
  • I ran the command you supplied and the databases appear mounted and healthy.

    If by rebooting Exchange Server, you mean my server and not the database, then I have already done that when I installed the RU16 bundle.  I do not have immediate access to the Exchange database servers, but I could probably get them rebooted if you think it might help.

    I am not an AD expert, so I'm not sure what you mean exactly when you say "multiple AD Sites".  If I open up Active Directory Users and Computers and choose to "Change Domain Controller", I do see a list of multiple domain controllers available for the domain. Is that what you are referring to?

    Thursday, March 16, 2017 3:23 PM
  • You should learn about your AD site topology because it's very important to Exchange.  Automatic database selection requires mailbox servers to be in the same AD site as where you're running the commands since only servers in the same site are selected.

    Make sure your Exchange session connected to a server in the site where you want the mailbox provisioned.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    • Proposed as answer by Lynn-Li Thursday, April 6, 2017 5:16 AM
    Friday, March 17, 2017 6:36 AM
  • Your explanation makes sense to me. I will contact our AD team and see if I can make some headway there. I'll report back with results next week. Thanks!
    Friday, March 17, 2017 6:43 PM
  • Good luck!

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."
    Celebrating 20 years of providing Exchange peer support!

    Saturday, March 18, 2017 2:04 AM
  • Has there been any changes made to your active directory sites ? I have seen this in the past when the AD Site's naming convention is an issue.

    Refer to the post: https://social.technet.microsoft.com/Forums/exchange/en-US/726a0d38-b92d-43dd-8993-761aac959b0b/load-balancing-failed-to-find-a-valid-mailbox-database?forum=exchange2010

    Could you please brief me about your setup. Do you have exchange server spanned across multiple AD Sites ?

    Enabling diagnostic logging on "Active manager " manager would help.

    Is the console connecting to server in the primary data center or to a different server in a different data center ?

    Did you try New-Mailbox cmd using Powershell and checked if mailbox provisioning is successful when a database not specified ?

    Also, This problem may be caused by Remote PowerShell because one child script doesn’t respect site-link cost effectively even though some codes are in place.

    Any action performed even by EMC would run a Powershell command in the back ground. so i guess this might be something to do with site-cost link and when the mailbox provosioning agent is trying to get hold of the information about the databases in the other site.

    can you try below workaround and confirm if it works ?
    1. Change AD Site Name of the Primary Datacenter Higher alphabetically.


    Pavan Maganti ~ ( Exchange | 2003/2007/2010/E15(2013)) ~~ Please remember to click “Vote As Helpful" if it really helps and "Mark as Answer” if it answers your question, “Unmark as Answer” if a marked post does not actually answer your question. ~~ This Information is provided is "AS IS" and confers NO Rights!!

    Monday, March 20, 2017 2:24 PM
  • Your explanation makes sense to me. I will contact our AD team and see if I can make some headway there. I'll report back with results next week. Thanks!

    Hi, pineconesundae

    Any updates from AD team?


    Best Regards,

    Lynn-Li
    TechNet Community Support


    Please remember to mark the replies as answers.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, March 27, 2017 2:16 PM
  • Hi,

    We were having the same issue and it looks like the databases were excluded from provisioning. Can you please run the following commands in exchange

    Get-mailboxdatabase | ft name,isexcludedfromprovisioning

    Get-mailboxdatabase | ft name,issuspendedfromprovisioning

    If the answer is true than that would be the culprit. Run the following commands to enable it depending on which query provided the True answer

    Set-MailboxDatabase "MailboxDatabaseName" -IsSuspendedFromProvisioning $false

    Set-MailboxDatabase "MailboxDatabaseName" -IsExcludedFromProvisioning $false

    Normally this happens if the disk space is running low

    Please mark this as an answer if it works

    Thanks



    • Edited by MoZubbeer Tuesday, July 30, 2019 11:16 PM
    • Proposed as answer by Makulai Monday, November 4, 2019 8:06 AM
    Tuesday, July 30, 2019 10:18 PM
  • Great, worked for me!
    Monday, November 4, 2019 8:06 AM