locked
Problem displaying Arabic characters in multiple browsers RRS feed

  • Question

  • Dear Microsoft and everyone else,

    As an IT professional in the Arab world, we're all kind of wondering why Internet Explorer 8 (and for that matter, Firefox) does not properly display all aspects of Arabic script in UTF-8. Strangely enough, this problem only occurs in browsers, but using both the Trident and Gecko rendering engines. Allow me to show you:
    Photobucket
    That's what it looks like on Facebook here, in both browsers. It should look like this: سري الحسيني without the thing that looks like a lightbulb in there, or with the last two letters (ني) being on the right side of the second line of his name.

    This has only been a problem since the Win7 upgrade, and we're worried we're going to find more issues. UTF-8 has never been a problem before, so we figure it's something since 7 was installed.
    Wednesday, November 4, 2009 8:12 PM

All replies

  • Hi,

     

    I suggest you check the following steps:

     

    1. Click "Start", type "inetcpl.cpl" (without quotation marks) into “Search” bar and press "Enter" to open the “Internet Options” window.

    2. Click “Languages” button under “General” tab.

    3. Click “Add…” to add the Arabic language and click “OK”.

    4. Highlight the Arabic language, click “Move up” and click “OK”.

    5. Click “OK” and restart Internet Explorer 8 to check the issue.

     

    If it does not work, I also suggest you perform the following steps.

     

    1.    Click "Start", “Control Panel”, “Clock, Language, and Region” and “Region and Language”.

    2.    Under “Formats” tab, change the Format to Arabic.

    3.    Switch to “Location” tab, and confirm the current location.

    4.    Switch to “Administrative” tab, click “Change system locale…” to confirm the current system locale.

    5.    Click “OK” and restart the computer to check the issue.

     

    Good luck!

     


    Arthur Li - MSFT
    Thursday, November 5, 2009 8:35 AM
  • Thanks for the reply, Arthur, but unfortunately the problem is still occurring, even after both suggestions. It's not a big deal though; I'm sure that as more people throughout the world start using Win7, issues like this will crop up and be quickly solved through some updates and patches. If you have any other thoughts, just let me know.
    Saturday, November 7, 2009 6:38 PM