locked
Task Scheduler UI crashes upon launch RRS feed

  • Question

  • Hello,

    Last week, a customer called to report that her workstation was not booting. Long story short: There was a problem with the hard drive. I cloned the drive to a new disk and that brought the system back up. 

    While looking for damage after the clone, I noticed that the Task Scheduler UI does not launch. Specifically, if you open "Task Scheduler" from the Start menu, nothing appears. If you access the Task Schedule from Computer Management, Computer Management closes unexpected. (The same thing happens when you add-in the Task Scheduler to a new MMC.)

    To be sure, this problem could pre-date the hard drive problem. I really don't know.

    I have no reason to believe that task scheduling isn't working. The service runs and I've scheduled a task from the command line successfully. But, admittedly, the loss of user-friendliness is kind of a big deal to the end user. 

    The only evidence I've been able to track down so far is that with each crash, the Application Log shows

    EventID 1023: 

    .NET Runtime version 2.0.50727.5477 - Fatal Execution Engine Error (000007FEF80C54F6) (80131506)

    What I've tried:

    1. I've run the dotnet repair tool from Microsoft which found problems with 4.5 and repaired them.

    2. I ran SFC which reported it found problems and fixed them.

    3. I've tried known-good copies of Tasksched.msc.

    4. I've cleared out both the Tasks folder and the cache in the registry to see if a particular entry was causing the crash. No difference. 

    What am I missing?

    Cheers,

    m

    Friday, May 9, 2014 5:43 PM

All replies

  • Hi,

    What’s the result after you run this repair tool?

    Microsoft .NET Framework Repair Tool

    http://www.microsoft.com/en-us/download/details.aspx?id=30135

    check if you can apply this hotfix:

    FIX: The top of the call stack shows the mscorwks!WKS::gc_heap::mark_object_simple function after an exception occurs in a .NET Framework 2.0-based application

    http://support.microsoft.com/kb/974372


    Alex Zhao
    TechNet Community Support

    Tuesday, May 13, 2014 8:27 AM
  • Hello Alex,

    Regarding the first one, I have run that previously, but it only suggests repairing 4.5.1. I have done that but it hasn't fixed the issue.

    The second option was a little bit of a rabbit hole. The KB article references Windows XP. I seem to have found the related update for Windows 7 here:

    http://archive.msdn.microsoft.com/KB974372/Release/ProjectReleases.aspx?ReleaseId=3143

    I downloaded the MSU for x64 Windows 7 and the installer reports that the fix is not applicable. 

    Thanks for helping!

    m

    Tuesday, May 13, 2014 4:10 PM
  • Hi i have the same issue,

    .NET Runtime version 2.0.50727.5477 - Fatal Execution Engine Error (000007FEF7B254F6) (80131506)

    and 

    Faulting application name: mmc.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc808
    Faulting module name: mscorwks.dll, version: 2.0.50727.5477, time stamp: 0x5265c8ee
    Exception code: 0xc0000005
    Fault offset: 0x000000000018202e
    Faulting process id: 0x1634
    Faulting application start time: 0x01cf8fa11f90feeb
    Faulting application path: C:\Windows\system32\mmc.exe
    Faulting module path: C:\Windows\Microsoft.NET\Framework64\v2.0.50727\mscorwks.dll
    Report Id: 5d639fd0-fb94-11e3-a521-984be105f3a6

    cannot open mmc or ssms

    i had 2 SQL's 2005x86 and 2008 x64 removed 2005 no luck

    sfc /scannow - didn't  find any errors

    .net repair tool found and repaired 4.1 errors and still no luck

    any suggestions?

    Tuesday, June 24, 2014 12:22 PM