none
DPM Agent Installation error 346 and 277 RRS feed

  • Question

  • Hello,

    we are trying to install DPM Agent 2010 on different server (Windows 2003).

    We get different errors:

    Sometimes when we try to "deploy" the agent from DPM MMC, i can enter the credentials and after that, the installation begins and i get the following error:

    Install protection agent on <servername> failed:

    Error 346: DPM is unable to retrieve the configuration information from <servername>.

    Error details: There are no more endpoints available from the endpoint mapper

    Recommended action: Ensure that the Windows Management Instrumentation (WMI) service is started. If the firewall is turned on, on <servername> make sure that an exception for WMI is created

    ------------------------------------------------

    We have no firewall at dpm server and protected server enabled.

    I can ping fqdn from both server. Also wbemtest from dpm server seems to work.

    On other server i get the following error, directly after entering my credentials when i try to push the agent to the windows server:
    "Could not connect to the Service Control MAnager on <servername> (ID 277)."

    Also no firewall, i can ping fqn.

    Our DPM Server is english , windows server toprotect are german. We have agents which are working.

    I have updated DPM 2010 with latest Hotfix Rolup (March 2011).

    Can anybody help us?

    Thank you

    Regards

    Tuesday, September 6, 2011 7:19 PM

All replies

  • Hi

    Try to install the agnet manually, this is how you can do it:

    share the RA catalouge under the DPM installation path. Default path is C:\Program Files\Microsoft DPM\DPM\agents\RA.

    If you have the latest patch from march you'll have a catalouge named 3.0.7707.0. Run the DPMAgentInstaller_KB2465832_AMD64 if you have a 64 bit operating system that you want to protect.

    Did you get the same error?

     


    Best Regards

    Robert Hedblom

    MVP DPM


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Monday, September 26, 2011 9:54 AM
    Moderator
  • Hi,

    I had similar problems with some Windows 2003 servers.

    I checked nearly everything, WMI, DCOM, Firewall etc - verything seemed to be fine.

    After some further investigation I uninstalled the Hardware monitoring agent from the system manufacturer

    -> it worked !! After uninstalling and reinstalling the DPM Agent everything was fine.
    After that I could reinstall the hardware monitoring agent and both agents (DPM and hardware) were running without problems


    So you could try uninstalling agents like FTS ServerView, HP Insight Management Agents etc. or try to install those after installing the DPM agent...

    hope it helps

    regards

    /bkpfast

     

    Friday, November 4, 2011 2:39 PM
  • Please have a look at this URL http://support.microsoft.com/kb/839880


    Best Regards

    Robert Hedblom

    MVP DPM


    Check out my DPM blog @ http://robertanddpm.blogspot.com

    Monday, November 7, 2011 8:34 PM
    Moderator