none
HomeGroup: error 0x80630203 / Leaving/joining the homegroup is not possible

    Question

  • Hello,

    I have the following problems with the HomeGroup:

    I choose View or print the homegroup password: The password window does not pop up. Without the password no other computer can join the homegroup.

    I choose Change password: On your computer it is not possible to create a homegroup.

    I choose Leave the homegroup: Your computer could not leave the homegroup.

     

    I checked the following services:

    HomeGroup Provider: started

    HomeGroup Listener: started

    Peer Name Resolution Protocol: not started; error 0x80630203

    Peer Networking Grouping service: not started; error 1068.

    Peer Networking Identity Manager service: started

    PNRP Machine Name Publication Service: not started; error 1068.

     

    Who can give advice?

    Wednesday, June 30, 2010 4:00 PM

Answers

  • Clear all files inside C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking did not help at all.

     

    After searching for a long time, the following turned out to fix the problem: 

    C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys ----> Took over possession: Admin (my user account), security everyone added full possession 

    Cleared all files inside MachineKeys, restarted

    Then left the homegroup: Result: There is no homegroup available in the network 

    Now Network and Sharing Center shows again: 

    - access type: Internet

    - homegroup: ready to create

    - connections: wireless network connection


    C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys ----> security everyone deleted full possession

    • Marked as answer by Joe Bush Saturday, July 24, 2010 8:26 AM
    Saturday, July 24, 2010 8:22 AM
  •  

    Hi,

     

    To leave HomeGroup completely, please perform the following steps.

     

    a. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. In the popup window, type the following commands and press Enter one by one:

     

    Net stop p2pimsvc

     

    2. Access t he following folder and clear all files inside:

     

    C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking

     

    3. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

     

    Net start p2pimsvc

     

    If the issue persists, I suggest you upgrade the virus definition and run a complete scanning for a test.

     

    Thanks,

    Novak


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Novak Wu Monday, July 5, 2010 1:41 AM
    Thursday, July 1, 2010 3:20 AM

All replies

  •  

    Hi,

     

    To leave HomeGroup completely, please perform the following steps.

     

    a. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

     

    Note: If you are prompted for an administrator password or confirmation, type your password, or click Continue.

     

    b. In the popup window, type the following commands and press Enter one by one:

     

    Net stop p2pimsvc

     

    2. Access t he following folder and clear all files inside:

     

    C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking

     

    3. Click the Start Button, type "cmd" (without quotation marks), in the search result list, right click on Cmd.exe and select Run as administrator.

     

    Net start p2pimsvc

     

    If the issue persists, I suggest you upgrade the virus definition and run a complete scanning for a test.

     

    Thanks,

    Novak


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by Novak Wu Monday, July 5, 2010 1:41 AM
    Thursday, July 1, 2010 3:20 AM
  • Clear all files inside C:\Windows\ServiceProfiles\LocalService\AppData\Roaming\PeerNetworking did not help at all.

     

    After searching for a long time, the following turned out to fix the problem: 

    C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys ----> Took over possession: Admin (my user account), security everyone added full possession 

    Cleared all files inside MachineKeys, restarted

    Then left the homegroup: Result: There is no homegroup available in the network 

    Now Network and Sharing Center shows again: 

    - access type: Internet

    - homegroup: ready to create

    - connections: wireless network connection


    C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys ----> security everyone deleted full possession

    • Marked as answer by Joe Bush Saturday, July 24, 2010 8:26 AM
    Saturday, July 24, 2010 8:22 AM
  • Joe Bush,

    You're the man!! Thanks for posting your solution. It solved my problem.

     

    Thursday, November 25, 2010 3:01 PM
  • Thanks Joe Bush;

    I did the same thing but I didn't delete the MachineKeys file. Instaed I renamed MachineKeys_old and created a new file in the same folder called MachineKeys and gave full permission to Everyone and System. The 2 x Peer Name Resolution services started after I did this. After I rebooted I Joined the Homegroup succesfully.

    I am running AVG Internet Security 2010. I have the Homegroup entry in the active firewall profile set "Allow from all" and the same for all IPv6 services and protocols.

    Rename:  C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys To: C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys_old

    Create a new: C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys and set permissions Everyone Full control


    The VipX
    Friday, February 18, 2011 10:03 PM
  • hi, after 3 days of total frustration trying to leave the corrupted homegroup and set up a new one, your solution is the only

    one that worked ....!!! Thanks

    Tuesday, November 15, 2011 1:42 PM
  • Thanks Joe Bush;

    I did the same thing but I didn't delete the MachineKeys file. Instaed I renamed MachineKeys_old and created a new file in the same folder called MachineKeys and gave full permission to Everyone and System. The 2 x Peer Name Resolution services started after I did this. After I rebooted I Joined the Homegroup succesfully.

    I am running AVG Internet Security 2010. I have the Homegroup entry in the active firewall profile set "Allow from all" and the same for all IPv6 services and protocols.

    Rename:  C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys To: C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys_old

    Create a new: C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys and set permissions Everyone Full control


    The VipX
    This was it for me...I had to provide Full access to Everyone in order to get pnrpsvc started.
    • Proposed as answer by Aneshpatel Sunday, March 31, 2013 4:31 AM
    Saturday, June 2, 2012 3:52 PM
  • thanks this worked for me.. after soo much fustration..
    Sunday, March 31, 2013 4:32 AM
  •   C:\ProgramData\Microsoft\Crypto\RSA\MachineKeys

    I get the same problem, but don't even have a directory ProgramData.  Any suggestions?

    Friday, September 27, 2013 6:12 PM
  • oh, just realized it was hidden (Folder options)
    Friday, September 27, 2013 8:02 PM
  • great, it worked for me too. i had struggling with this for a long time and finding your solution it's really a relief
    Wednesday, November 18, 2015 4:04 PM
  • Thanks Joe. I spent a whole day frustrated and have avoided networking my computers for a couple months after failed attempts due tot his issue. Everything appears to be working the way it should.  Much appreciation
    Thursday, June 23, 2016 1:22 PM
  • I've tried everything on the face of the earth and nothing works. I'd try this but my laptop doesn't HAVE a Program Data folder.

    Any other guidance would be appreciated.

    Sunday, January 22, 2017 9:25 PM
  • Incomprehensible that the homegroup troubleshooter still does not take control of this issue. It's apparent already (over?) 7 years!
    My problem (homegroup 3x Windows 10) is at least resolved.
    Thank you a lot.
    Sunday, September 3, 2017 3:09 PM
  • Go to C:\ProgramData\Microsoft\Crypto\RSA and right-click on MachineKeys - Properties - Security
    and
    add Local Service to the Groups or user names. 
    To do so, click edit - Add - and type "local service" and hit check names,
    then click "OK" and click "Full Control" under "permissions" for local service, click "OK". Now, start all three services.
    Sunday, December 3, 2017 5:07 AM
  • 7 years later, my google'ing brought me here. This fix still worked on Windows 10 64bit 1709 getting 0x80630203. Thank you
    Saturday, January 13, 2018 1:29 AM
  • This fixed my being unable to join the Home Group on my Windows 10 file server.

    Gerry

    Wednesday, March 28, 2018 10:34 PM