Not getting login page when I connect to public wifi RRS feed

  • Question

  • I'm here at a hospital with free wifi. However, when you first connect, it redirects you to a webpage which describes their usage policy and a form for you to submit your email address.

    It works fine with my iPhone and iPad, but, with my Windows 8.1 Enterprise laptop, when I choose to connect to that wifi network, I am never redirected to this webpage. Windows only tells me that the connection is "Limited".

    How do I fix this?

    Thursday, July 10, 2014 10:22 PM


All replies

  • Jemenake

    You may have something blocking the redirection on your laptop.  Are you using private browsing?  Do you have an add on blocking scripting, etc.  Have you tried a different browser?

    Wanikiya and Dyami--Team Zigzag

    • Proposed as answer by naeguh Thursday, October 19, 2017 12:18 PM
    Friday, July 11, 2014 12:10 AM
  • Hi,

    Did you resolve your issue? Could you connect other WIFI using your Windows 8.1 laptop?

    If no, please troubleshoot your issue as below article:

    Windows 8.1 Wifi showing "limited" or "No Internet Access"

    Karen Hu
    TechNet Community Support

    Wednesday, July 16, 2014 3:11 AM
  • So, I solved my problem. I did it by setting Internet Explorer as the default HTTP and HTTPS handler. Then, when I connected to the wifi, I was prompted with the HTML-based login/eula screen. Interestingly, after that, I set the default HTTP/HTTPS app back to be Chrome, and then *Chrome* was able to handle the logins. So, I think something got "disconnected" somewhere, and messing with the default app for HTTP/HTTPS was able to fix it.
    • Marked as answer by Jemenake Thursday, July 24, 2014 6:00 PM
    Thursday, July 24, 2014 5:59 PM
  • I had the same problem, accessing a guest wifi network that automatically loads the login webpage.

    Tracked it down to app permissions in the end, after installing Firefox it had become default for html, but not default for http/https. After I reverted everything back to IE was able to access the wifi network login portal.

    Wednesday, May 6, 2015 10:24 PM
  • I had a similar problem.  The issue is the login/"agree to internet usage terms" page trying to pop-up, but the browser won't let it.  So the network never sees that you agreed to terms, and won't give full access.  But the computer is talking to a network and indicates 'limited.'

    The other solutions on this page probably work.

    Other work-arounds that may help include, when you get to the 'can't open this site' page in the browser try any of:

    Type in "login" in the address window

    Type the name of the provider, e.g. at the airport, if its Boingo hotspot, try typing "boingo" in the address window.  That worked for me.

    Other threads noted that disabling the browser pop-up blocker may work.

    Also, in some cases only IE works (not Firefox, Chrome, etc.)

    Good luck

    • Proposed as answer by Kinnettt Wednesday, September 5, 2018 11:36 AM
    Thursday, April 20, 2017 8:58 PM
  • I had the same problem on my MAC.  After looking at DNS entries and permissions and proxies and everything else I could find I noticed that when I tried on my iphone it briefly redirected to before getting the log in prompt.   I typed in to my browser and viola I get he wifi login prompt,   this works for united in the lounge and on the plane,  xfinity, boingo and a bunch of offices I have visited for work ..

    So all I can conclude is that may be the default IP address for the user login page on wifi access points

    I hope this helps

    • Proposed as answer by meganclrk0 Wednesday, March 28, 2018 6:17 PM
    Tuesday, June 13, 2017 4:05 PM
  • On my Win10 laptop it helped to temporarily disable the firewall (Settings->Network&Internet->Windows Firewall) and the login page showed up.
    Wednesday, March 21, 2018 9:31 PM
  • This worked for me on a Windows 7 laptop. THANK YOU!
    Wednesday, March 28, 2018 6:17 PM
    Saturday, February 23, 2019 10:12 PM
  • Legend. Typing Login is the only thing that worked for me.  So weird!

    Friday, April 5, 2019 2:55 AM