locked
Cannot install Active Directory on Server 2008 R2 SP1 RRS feed

  • Question

  • I have this issue on my Server 2008. Error message is "Active Directory Domain Services Installer : Failed to install Active Directory binaries. The error was : Element not found.

    I ran Windows Update Readiness tool, it doesn't find any error. Also ran SFC and DISM no error there either.

    This is the error code from a log file "error -2147023728". (forgot where that is.) I've been working on this for two days and could find any solution. 

    I've done everything from deleting software distribution folder to re-registering services and removing updates. I tried it from Server manager and dcpromo. Both come back with error. This is the error code from server manager.

    Can't install Roles and Features - receive "Element not found. Error: 0x80070490" 

    I've also tried to disable my antivirus and it is the same result.

    Monday, March 25, 2019 5:06 AM

Answers

  • Hi,

     

    Please refer to the following link to reset Windows Update components:

    Windows Update - additional resources

    https://docs.microsoft.com/en-us/windows/deployment/update/windows-update-resources

     

    After that, restart Windows Update service in Services.msc and try to reinstall again.

     

    If the issue still persists, you may upload CBS.log through OneDrive and attach the shared link in your reply.

     

    Please understand that from our professional level, we do not provide dump analysis. But from my personal point of view, I still hope to do my best to help you analyze. In addition, if this problem is more urgent for you I still recommend that you open a case to Microsoft for further professional help.

     

    Hope these can help you. If you have any questions, please feel free to contact us.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 26, 2019 3:01 AM

All replies

  • Hi,

     

    Please refer to the following link to reset Windows Update components:

    Windows Update - additional resources

    https://docs.microsoft.com/en-us/windows/deployment/update/windows-update-resources

     

    After that, restart Windows Update service in Services.msc and try to reinstall again.

     

    If the issue still persists, you may upload CBS.log through OneDrive and attach the shared link in your reply.

     

    Please understand that from our professional level, we do not provide dump analysis. But from my personal point of view, I still hope to do my best to help you analyze. In addition, if this problem is more urgent for you I still recommend that you open a case to Microsoft for further professional help.

     

    Hope these can help you. If you have any questions, please feel free to contact us.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 26, 2019 3:01 AM
  • Since a new domain controller time may be better spent clean installing it, patch fully and try adding roles again.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Tuesday, March 26, 2019 3:13 AM
  • Hi,

    Was your issue solved?

    If yes, would you like to share your solution in order that other community members could find the helpful reply quickly.

    If no, please reply and tell us the current situation in order to provide further help.

    Best


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, March 28, 2019 9:51 AM