none
Hyper-V 2016 Standalone: No active network adapters found

    Question

  • I'm building a new machine using Asus Z270-A motherboard which has an integral Intel gigabit ethernet interface.  I have flashed the BIOS to the latest version and the NIC is visible in the BIOS.  I've installed Hyper-V 2016 onto a pristine disk.  After setting an Administrator password it launches sconfig, which tells me "No active network adapters found". The NIC works, at least in the sense that I see power and activity LEDs doing their things when connected to my network.

    From PowerShell, Get-NetAdapter -Name "*" returns nothing and it does so immediately. I downloaded the latest NIC driver from ASUS and attempted to install the Win2016_x64 drivers however it returns that there are no Intel interfaces installed.  I ran pnputil to manually add the drivers, rebooted, and there is no change.

    Any suggestions on how to debug this?

    Friday, February 17, 2017 4:15 PM

Answers

  • This has been quite the learning experience and I very much appreciate your help.  waingro's suggestion eventually led me to a solution.


    First, Windows 10 installed fine, so the problem was clearly OS and not hardware.


    The foxdeploy.com link was dealing with a similar problem, but in that case the driver was explicitly excluded in the .inf file, which was not my probem. But the links from that file, some additional Googling, and a bit of trial-and-error in the BIOS eventually got me to a solution.


    The .inf file from Intel enables the ethernet for Windows 10 Workstation versions, but does not enable it for Windows Server 2016. Taking a lead from folks who wanted to run Windows Server 2016 on NUC devices (references below) I modified the .inf to include my device in the section that applies to non-workstation versions of Windows 10. Then came the challenges of actually installing the driver, which required disabling Secure Boot in the BIOS and then configuring Hyper-V to boot to a test mode that allowed me to load unsigned drivers. Simple...


    So, for any fellow travelers who want to reproduce my steps (not that I recommend it):


    On some other machine, download and expand the Intel LAN drivers to disk and navigate down to the appropriate .inf file. At the time I did this the current version was 21.1 so, for my motherboard, I found myself at ...\Intel_LAN_Driver_Win7-81-10_V211300\PRO1000\Winx64\NDIS65\e1d65x64.inf


    Edit e1d65x64.inf and from the [Intel.NTamd64.10.0.1] section copy these three lines:


    %E15B8NC.DeviceDesc%            = E15B8.10.0.1,       PCI\VEN_8086&DEV_15B8
    %E15B8NC.DeviceDesc%            = E15B8.10.0.1,       PCI\VEN_8086&DEV_15B8&SUBSYS_00008086
    %E15B8NC.DeviceDesc%            = E15B8.10.0.1,       PCI\VEN_8086&DEV_15B8&SUBSYS_00011179

    and paste them into the [Intel.NTamd64.10.0] section of the file. (This takes the entries for my driver -- that occur only in the Windows 10 Workstation section of the signed driver file -- and replicates them in the section that applies to other Windows 10 derivative operating systems. This is also what 'unsigns' the driver.)  Save this file. I then copied the entire Intel_LAN_Driver_Win7-81-10_V211300 tree onto a thumb drive I could access from the Hyper-V server (though I'm sure I only needed a much smaller set of files). Now it was time to get into the server's BIOS...


    I entered the ASUS BIOS, shifted to Advanced Mode displays, and navigated to the Boot tab. From there I scroll down to the Secure Boot section and change OS Type to "Other OS", save and exit (F10), and reboot and login to Hyper-V.

    Back to Hyper-V I can now disable the driver signature enforcement

    bcdedit /set LOADOPTIONS DISABLE_INTEGRITY_CHECKS
    bcdedit /set TESTSIGNING ON
    bcdedit /set NOINTEGRITYCHECKS ON


    and reboot yet again.


    Now I insert the thumb drive, navigate to PRO1000\Winx64\NDIS65\, where the modified driver files are, and type


    pnputil /add-driver e1d65x64.inf


    and reboot yet again.


    This time I find the network interface working, so it's time to re-secure.


    bcdedit /set LOADOPTIONS ENABLE_INTEGRITY_CHECKS
    bcdedit /set TESTSIGNING OFF
    bcdedit /set NOINTEGRITYCHECKS OFF

    and reboot yet again.


    Back into the BIOS and change OS Type back to "Windows UEFI mode", save and exit (F10).

    and reboot yet again.


    And now I have Hyper-V 2016 running on my Z270-A motherboard with a network.


    References:
    http://blog.citrix24.com/install-windows-server-2016-core-intel-nuc/
    http://branderonline-public.sharepoint.com/Blog/Post/64/Running-Windows-Server-2016-CTP4-on-an-Intel-NUC-5i5RYH
    https://msdn.microsoft.com/en-us/windows/hardware/drivers/install/combining-platform-extensions-with-operating-system-versions

    Sunday, February 19, 2017 2:47 AM

All replies

  • If the NIC is integrated then you'll likely also need the mobo chipset installed.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

    Friday, February 17, 2017 4:22 PM
  • I quite wanted this to be the issue, but it didn't help.  I installed the latest chipset drivers and rebooted.  Still no NIC seen.  Tried again to install network drivers but program says no Intel interfaces found.  Used pnputil to add drivers manually but that didn't help either.  Tried re-installing Hyper-V and adding drivers with the installation but no luck.
    Saturday, February 18, 2017 3:37 AM
  • Difficult to say, it may be problematic that it's a desktop board. Might also try installing 2016 in gui mode or windows 10 + hyper-v

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.


    Saturday, February 18, 2017 4:10 AM
  • Since the motherboard doesn't list 2016 as a supported OS you'll likely need to "hack" the NIC drivers and install them. Something like this:

    https://foxdeploy.com/2013/09/12/hacking-an-intel-network-card-to-work-on-server-2012-r2/

    Alternatively, installing Windows 10 would be much easier and faster.

    Saturday, February 18, 2017 5:58 AM
  • Installing Server 2016 Essentials also failed to find an adapter.  I'll see if I can find a Windows 10 disk to test with; it won't satisfy my server requirements but it could help rule out a motherboard problem.  

    If Win10 fails I'll dig into your suggested hack.  I'm a bit pessimistic though as the latest (21.1) Intel driver package does list "Support for Microsoft Windows Server 2016" in the What's New section of the README and has a ...\PROSETDX\Win2016_x64 directory to back up that claim.

    Saturday, February 18, 2017 2:31 PM
  • Intel driver package does list "Support for Microsoft Windows Server 2016" in the What's New section of the README

    You might have the perspective turned around. The package may also supports other boards.

     

     



    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.



    Saturday, February 18, 2017 2:40 PM
  • This has been quite the learning experience and I very much appreciate your help.  waingro's suggestion eventually led me to a solution.


    First, Windows 10 installed fine, so the problem was clearly OS and not hardware.


    The foxdeploy.com link was dealing with a similar problem, but in that case the driver was explicitly excluded in the .inf file, which was not my probem. But the links from that file, some additional Googling, and a bit of trial-and-error in the BIOS eventually got me to a solution.


    The .inf file from Intel enables the ethernet for Windows 10 Workstation versions, but does not enable it for Windows Server 2016. Taking a lead from folks who wanted to run Windows Server 2016 on NUC devices (references below) I modified the .inf to include my device in the section that applies to non-workstation versions of Windows 10. Then came the challenges of actually installing the driver, which required disabling Secure Boot in the BIOS and then configuring Hyper-V to boot to a test mode that allowed me to load unsigned drivers. Simple...


    So, for any fellow travelers who want to reproduce my steps (not that I recommend it):


    On some other machine, download and expand the Intel LAN drivers to disk and navigate down to the appropriate .inf file. At the time I did this the current version was 21.1 so, for my motherboard, I found myself at ...\Intel_LAN_Driver_Win7-81-10_V211300\PRO1000\Winx64\NDIS65\e1d65x64.inf


    Edit e1d65x64.inf and from the [Intel.NTamd64.10.0.1] section copy these three lines:


    %E15B8NC.DeviceDesc%            = E15B8.10.0.1,       PCI\VEN_8086&DEV_15B8
    %E15B8NC.DeviceDesc%            = E15B8.10.0.1,       PCI\VEN_8086&DEV_15B8&SUBSYS_00008086
    %E15B8NC.DeviceDesc%            = E15B8.10.0.1,       PCI\VEN_8086&DEV_15B8&SUBSYS_00011179

    and paste them into the [Intel.NTamd64.10.0] section of the file. (This takes the entries for my driver -- that occur only in the Windows 10 Workstation section of the signed driver file -- and replicates them in the section that applies to other Windows 10 derivative operating systems. This is also what 'unsigns' the driver.)  Save this file. I then copied the entire Intel_LAN_Driver_Win7-81-10_V211300 tree onto a thumb drive I could access from the Hyper-V server (though I'm sure I only needed a much smaller set of files). Now it was time to get into the server's BIOS...


    I entered the ASUS BIOS, shifted to Advanced Mode displays, and navigated to the Boot tab. From there I scroll down to the Secure Boot section and change OS Type to "Other OS", save and exit (F10), and reboot and login to Hyper-V.

    Back to Hyper-V I can now disable the driver signature enforcement

    bcdedit /set LOADOPTIONS DISABLE_INTEGRITY_CHECKS
    bcdedit /set TESTSIGNING ON
    bcdedit /set NOINTEGRITYCHECKS ON


    and reboot yet again.


    Now I insert the thumb drive, navigate to PRO1000\Winx64\NDIS65\, where the modified driver files are, and type


    pnputil /add-driver e1d65x64.inf


    and reboot yet again.


    This time I find the network interface working, so it's time to re-secure.


    bcdedit /set LOADOPTIONS ENABLE_INTEGRITY_CHECKS
    bcdedit /set TESTSIGNING OFF
    bcdedit /set NOINTEGRITYCHECKS OFF

    and reboot yet again.


    Back into the BIOS and change OS Type back to "Windows UEFI mode", save and exit (F10).

    and reboot yet again.


    And now I have Hyper-V 2016 running on my Z270-A motherboard with a network.


    References:
    http://blog.citrix24.com/install-windows-server-2016-core-intel-nuc/
    http://branderonline-public.sharepoint.com/Blog/Post/64/Running-Windows-Server-2016-CTP4-on-an-Intel-NUC-5i5RYH
    https://msdn.microsoft.com/en-us/windows/hardware/drivers/install/combining-platform-extensions-with-operating-system-versions

    Sunday, February 19, 2017 2:47 AM
  • LearnSomethingNewEveryDay,

    You are the man.  This worked perfectly for me with ASUS Z170-AR motherboard.

    Tuesday, August 14, 2018 1:32 AM