none
Changed WSS Timer Service Account password - No login RRS feed

  • Question

  • Hi!

    I am running a Project Server 2007. I've now changed the WSS Timer Service Account password.
    The Windows SharePoint Services Timer service is running. I've restarted the service and the IIS after chaning the password.

    The problem is:
    I cannot login to PWA, I cannot logon to the server via Project 2007.
    PWA tells me: ERROR - An unexpected error has occurred.
    Project 2007 tells me: Login failed. Project could not connect to the server.

    Where else do I have to update the password of the WSS Timer Service AD Account?

    Thanks for your help!


    Regards, Selix.


    • Edited by Selix Tuesday, January 10, 2012 9:37 PM
    Tuesday, January 10, 2012 9:35 PM

Answers

  • Hi Selix,

    Please follow this guide to update farm credentials:

    http://support.microsoft.com/kb/934838

    SharePoint will need to know about the updated credentials, use the stsadm commands to do this.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    • Marked as answer by Selix Tuesday, January 10, 2012 10:51 PM
    Tuesday, January 10, 2012 10:09 PM
    Moderator
  • Paul, you definitely saved my life!!

    I did the steps
    1a, 1b, 1d
    2
    3
    1d again

    And it works! I am restarting the server just to make sure everything is ok but I already successfully logged in to PWA.

    Thank you very, very much, Paul!
    Much appreciated!
    Regards, Selix

    • Marked as answer by Selix Tuesday, January 10, 2012 10:51 PM
    Tuesday, January 10, 2012 10:51 PM

All replies

  • Hi Selix,

    Please follow this guide to update farm credentials:

    http://support.microsoft.com/kb/934838

    SharePoint will need to know about the updated credentials, use the stsadm commands to do this.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    • Marked as answer by Selix Tuesday, January 10, 2012 10:51 PM
    Tuesday, January 10, 2012 10:09 PM
    Moderator
  • In the event log I've got the following errors:

    W3SVC Event ID 1021

    W3SVC Event ID 1057

    W3SVC Event ID 1059

     

    I've updated the password in the application pool <ServiceName>. The servicewsstimer account is running this application pool. But everytime I start the application pool and restart the IIS, the application pool stops and I receive those errors.

     

    Event ID 1021:

    The identity of application pool, 'ServiceName' is invalid.  If it remains invalid when the first request for the application pool is processed, the application pool will be disabled.  The data field contains the error number.

    Event ID 1057:

    The identity of application pool 'ServiceName' is invalid, so the World Wide Web Publishing Service can not create a worker process to serve the application pool.  Therefore, the application pool has been disabled.

    Event ID 1059:

     failure was encountered while launching the process serving application pool 'ServiceName'. The application pool has been disabled.

    Tuesday, January 10, 2012 10:11 PM
  • Hi there,

    If you run through all of the steps in the article that should resolve the errors.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Tuesday, January 10, 2012 10:24 PM
    Moderator
  • Hi Paul!
    Thanks for the quick reply!

    As I dont want to create more damage as already done:

    If the Sharepoint Administration Console and the Project Server are on the same server and if I only changed the WSS Timer Service account password, I should be fine with steps:

    1a, 1b, 1d

    2

    3

    Is this correct? I didnt change the password of the WSS Search account and we do not have a farm, just a dedicated server for Sharepoint and Project.

    Thank you very much!
    Selix

    Tuesday, January 10, 2012 10:29 PM
  • Hi Selix,

    Carry out all of the following steps:

    • 1 (will update the farm service account credentials)
    • 2
    • 3
    • 6a (update the SSP account)

    Depending on what accounts you have set up on your farm and what passwords you have updated in AD, you might only need to update the farm credentials.

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com
    Tuesday, January 10, 2012 10:41 PM
    Moderator
  • Paul, you definitely saved my life!!

    I did the steps
    1a, 1b, 1d
    2
    3
    1d again

    And it works! I am restarting the server just to make sure everything is ok but I already successfully logged in to PWA.

    Thank you very, very much, Paul!
    Much appreciated!
    Regards, Selix

    • Marked as answer by Selix Tuesday, January 10, 2012 10:51 PM
    Tuesday, January 10, 2012 10:51 PM