locked
Inserting option to deploy application RRS feed

  • Question

  • Hi All,

    I am currently trying to install drivers' software (Lenovo System Update and HP Softpaq Download Manager) based on make from the same task sequence.

    I created two steps "Install Applications", selected "Single Application" and put the two software mentioned above. The software are hidden in the deployment wizard.

    I proceeded at creating a rule to be put in the task sequence step:

    -If all conditions are true

    Task Sequence variable make equals Hewlett-Packard/Lenovo (respectively).

    The software, unfortunately, does not get installed. I also tried with %make% but the result is the same.

    Do you have any idea of what I am doing wrong?

    Thanks

    Daniele

    Thursday, May 22, 2014 9:51 AM

Answers

  • Easy solution:


    Create 2 different task sequence for each software application.

    Then change your conditions to:

    1st task - Task Sequence Variable (Make) equals Lenovo 
    2nd task - Task Sequence Variable (Make) equals Hewlett-Packard

    Second solution:
    Create one install script that works with MDT variable and perform a check on the Make property

    oEnvironment.Item("Make")

    Third solution, use the Rule file customsettings.ini:

    [Settings]

    Priority=ByType,Default

    Properties=MyCustomProperty

     
    [Hewlett-Packard]

    MandatoryApplications001={cdf5444c-abce-4de2-8375-fc5b9c8ff523}

    [Lenovo]

    MandatoryApplications001={cdf5dffc-abce-4de2-8375-fc5b9c8ff524}
     






    Thursday, May 22, 2014 10:38 AM
  • Back again with the solution!

    Thomas put me on the right track but I had to fine-tune his example in order for it to work. I invoked Bymake and defined it as follows:

    [Settings]
    Priority=ByMake, Default
    Properties=MyCustomProperty
    
    [ByMake]
    Subsection=Make-%Make%
    
    [Make-Lenovo]
    UILanguage=en-US
    UserLocale=en-UK
    KeyboardLocale=0809:00000809
    MandatoryApplications001={ad7e2f04-0a3d-4d3d-8b8d-f1b5f1020d10}
    
    [Make-Hewlett-Packard]
    UILanguage=en-US
    UserLocale=en-UK
    KeyboardLocale=0409:00000409
    MandatoryApplications002={49745a28-cad9-4e08-9a66-770b91f86547}
    

    It works great!

    Thanks a lot, Thomas!

    Thursday, May 22, 2014 4:13 PM

All replies

  • Easy solution:


    Create 2 different task sequence for each software application.

    Then change your conditions to:

    1st task - Task Sequence Variable (Make) equals Lenovo 
    2nd task - Task Sequence Variable (Make) equals Hewlett-Packard

    Second solution:
    Create one install script that works with MDT variable and perform a check on the Make property

    oEnvironment.Item("Make")

    Third solution, use the Rule file customsettings.ini:

    [Settings]

    Priority=ByType,Default

    Properties=MyCustomProperty

     
    [Hewlett-Packard]

    MandatoryApplications001={cdf5444c-abce-4de2-8375-fc5b9c8ff523}

    [Lenovo]

    MandatoryApplications001={cdf5dffc-abce-4de2-8375-fc5b9c8ff524}
     






    Thursday, May 22, 2014 10:38 AM
  • Hi Thomas,

    I decided to go for the third option because I am already using the By Type invocation for the Keyboard Locale.

    I will let you know as soon as the images are deployed onto my test machines! Thanks for the answer in the meantime!

    Daniele

    Thursday, May 22, 2014 12:06 PM
  • Back again with the solution!

    Thomas put me on the right track but I had to fine-tune his example in order for it to work. I invoked Bymake and defined it as follows:

    [Settings]
    Priority=ByMake, Default
    Properties=MyCustomProperty
    
    [ByMake]
    Subsection=Make-%Make%
    
    [Make-Lenovo]
    UILanguage=en-US
    UserLocale=en-UK
    KeyboardLocale=0809:00000809
    MandatoryApplications001={ad7e2f04-0a3d-4d3d-8b8d-f1b5f1020d10}
    
    [Make-Hewlett-Packard]
    UILanguage=en-US
    UserLocale=en-UK
    KeyboardLocale=0409:00000409
    MandatoryApplications002={49745a28-cad9-4e08-9a66-770b91f86547}
    

    It works great!

    Thanks a lot, Thomas!

    Thursday, May 22, 2014 4:13 PM
  • You're welcome Daniele, and good job!
    Thursday, May 22, 2014 4:46 PM