none
UAG remote desktop access RRS feed

  • Question

  • I have installed UAG with DA for evaluation. Configured UAG https trunk and published applications and remote desktop(predefined). Everything working fine and able to login externally to UAG portal with https://testportal.domain.com and launch applications and remote into UAG server through published Remote Desktop.

    However, till today i was able to remote into UAG server internally within network, but once i installed RemoteDesktop Gateway Manager, Remote Desktop Session Host server, I lost my remote access within internal network ( UAG is in DMZ and added to domain).

    I can remote into UAG server through external network port trunk. Is there any configuration issue preventing me remote into within network?

    I got the below error:

    "The remote computer "UAG.domain.com" returned an RDP protocol error (Return code:516).

     

    Thanks in advance for your help!

    Regards

     


    Tek-Nerd
    Wednesday, September 21, 2011 7:23 PM

Answers

  • Resolved.

     

    On UAG remote desktop connection settings " Allow connections only from Computers running Remote Desktop with Network level Authentication" selected, which is not not supported in XP. When i change the selection to "Allow connections from computers running any version of Remote Desktop" the issue has been resolved and able to remote into UAG server.


    Tek-Nerd
    • Marked as answer by Tek-Nerd Friday, September 23, 2011 2:23 PM
    Friday, September 23, 2011 2:23 PM

All replies

  • Hi,

    did u install these roles on uag itself?

    Cheers,

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/ Please remember to use “Mark as Answer” or "vote as helpful" on the posts that help you.
    Wednesday, September 21, 2011 9:01 PM
  • Yes, I installed these roles (RemoteDesktop Gateway Manager, Remote Desktop Session Host server) on UAG server
    Tek-Nerd
    Thursday, September 22, 2011 1:25 PM
  • Hi,

    sorry, but i am a little confused about what u are doing and why. If u are running uag the RDGateway Role is installed by default. The management console also. So here is no need to add this roles manually. U do not need to install the RDSessionHost Role also, because if u only want to manage uag remotely by using rdp, then this is possible also by default. U just need to add the Remote Management Computers to the System Policy in TMG. So, what is the goal of your configuration?

    Cheers,

    Andreas


    Andreas Hecker - Blog: http://microsoft-iag.blogspot.com/ Please remember to use “Mark as Answer” or "vote as helpful" on the posts that help you.
    Thursday, September 22, 2011 8:04 PM
  • > add the Remote Management Computers to the System Policy in TMG

     

    My desktop IP address already added to the system policy, and i used to remote into UAG server before i published 'RemoteDesktop(Predefined)' in UAG portal.

    As i am evaluating UAG for our SharePoint team to roll in production, i want to explore.

     


    Tek-Nerd
    Friday, September 23, 2011 1:38 PM
  • Resolved.

     

    On UAG remote desktop connection settings " Allow connections only from Computers running Remote Desktop with Network level Authentication" selected, which is not not supported in XP. When i change the selection to "Allow connections from computers running any version of Remote Desktop" the issue has been resolved and able to remote into UAG server.


    Tek-Nerd
    • Marked as answer by Tek-Nerd Friday, September 23, 2011 2:23 PM
    Friday, September 23, 2011 2:23 PM