none
How do I filter by a task level enterprise custom field in a PWA project view? RRS feed

  • Question

  • I have created a project view within Manage Views on PWA. The view groups by just fine. When I create a filter for a task level enterprise field the view does not load in the Project Details Page.

    I have checked that the filter works for a standard task field. The filter on the task level enterprise field works when specified in the Project Details Page.

    However it will not work with specifying the filter on the view. It seems as though I can't filter by any task level enterprise fields.

    Tuesday, September 3, 2013 11:37 AM

All replies

  • Ross --

    Did you actually include the enterprise field in the list of fields displayed in the view?  If not, please try it and let us know the results.


    Dale A. Howard [MVP]

    Tuesday, September 3, 2013 11:57 AM
    Moderator
  • Hello Dale,

    Thanks for your response. The enterprise field is included in the view.

    Tuesday, September 3, 2013 12:33 PM
  • Hello Dale,

    Do you have any thoughts on this? It is worth mentioning that when applying the filter in the project details page I am only presented with the fields associated to the view. When I am setting up the filter in the manage views area I can see the entire set of fields associated to the project.

    Many thanks

    Ross

    Thursday, September 5, 2013 2:07 PM
  • Ross --

    I do not know why your filter is not working.  I just created a new enterprise Project view, included one custom enterprise Task field in the view (it has a lookup table attached to the field) in the view, and created a filter on that custom enterprise Task field.  I did have to fight a bit with the view filter settings a bit, however, as it would not allow me to use a Contains test.  But when I applied the custom Project view for an enterprise project in PWA, I was able to see that the correct tasks were displayed.

    You did not tell us what version of Project Server you are using.  I assumed the 2010 version.  Please let us know what version you are using, along with the current level of Service Packs and Cumulative Updates.  Thanks.


    Dale A. Howard [MVP]

    Thursday, September 5, 2013 6:46 PM
    Moderator