none
Unable to Save Project Schedule from Professional after upgrade to 2013 - Root Element missing RRS feed

  • Question

  • Hi,

    I have migrated Project Server 2010 to 2013 environment. The migration has been done successfully. However, when I try to save some projects from Project Professional 2013, the save operation fails. The error description for job failure mentions "Root Element" missing. 

    This happens only for some projects not all. I am unable to trace the cause of this issue.

    Any help in this regard would be appreciated.

    Wednesday, October 26, 2016 6:30 PM

All replies

  • I have seen this error when the Task 0 - the Project Task has a different name than the name of the saved project.

    I have also seen this when the Site Collection for PWA does not also have a root site collection with a valid site.

    Please check those items.

    Hope this helps,


    Thanks, Eric S. Pcubed

    Thursday, January 12, 2017 6:42 AM
  • Hi Abjijit,

    Root element missing is alas a fairly generic error unfortunately.  It would be worth checking the ULS logs further, but I've seen and heard the following solutions that have solved this...

    1. Do you see your plan in delete enterprise objects if you select ‘just published database’ - delete the plan from the published DB.

    2. Most times when I’ve seen 9000 errors there have been local custom fields with blank look up tables.  You might even see in the ULS logs a reference to LookupTableItemInvalidLookupTable.  It does appear to come and go – so clearing the cache and then starting with a fresh server copy could have helped here.

    3.  Save the file as XML and re-import (you will lose the formatting).  Save to Project Server.


    Ben Howard [MVP] | <a href="http://www.applepark.co.uk">web</a> | <a href="http://www.applepark.co.uk/ben-howard-blog">blog</a> | <a href="http:// www.microsoft.com/learning/en-us/book.aspx?id=16258&locale=en-u">book</a>

    Thursday, January 12, 2017 8:45 AM
    Moderator