locked
Remote Desktops always remembers "last server accessed" RRS feed

  • Question

  • A mild annoyance.  Since upgrading to Windows 7, when I run the Remote Desktops tool (in which I have configured about a dozen servers I normally need to access via remote desktop), upon exiting it "remembers" the server I was last accessing, and then when I re-enter Remote Desktops again, it has positioned itself on that server and it automatically logs in to that server ... and its almost never the one I want.

    The only workaround I have found is to always remember to click on the Remote Desktops top level entry in the Console Tree before exiting, so that when I come in next time it remembers that, and therefore won't login to any server.

    Does anyone know of a workaround for this behaviour?  In Vista, it would prompt on exit asking if you wanted to save settings.  Perhaps there might be a registry hack which can re-enable that Vista behaviour again?
    Tuesday, March 16, 2010 11:31 PM

All replies

  • Hi,

    On the Remote Desktop log on windows, click Options, under General tab, there are see more settings.  In your situation, you might need to check the following setting from group policy.

    Open "Local Group Policy Editor", navigate to Local Computer Policy/Computer Configuration/Administrative Templates/Windows Components/Remote Desktop Services/Remote Desktop connection Client, double click on it and enable the  "Do not allow passwords to be saved" and "Prompt for credentials on the client computer" to check the result.
    Wednesday, March 17, 2010 7:24 AM
  • Hi Frosty

    To get rid of the current history of your RDP history jump into regedit.


    HKCU\Software\Microsoft\Terminal Server Client\Default
    Delete String Values MRU0, MRU1...

    The logon name is stored in the default.rdp file in your Home Folder, i.e. My Documents, and is hidden by default.


    Kind Regards,

    Trent Steenholdt
    Wednesday, March 17, 2010 7:38 AM
  • Thanks for the suggestions.  Whilst they are close, no cigar!  Maybe I didn't explain myself well.  I am using the Remote Desktops tool (plural) which allows configuration of multiple Remote Desktop sessions.  I am not using the individual Remote Desktop app.  It looks like its some kind of wrapper application that is implemented as an MMC snap-in?  So rather than running:

        %systemroot%\system32\mstsc.exe

    which is the single Remote Desktop app, my shortcut is to:

      %windir%\system32\COMPANYNAME.msc /s

    and that file COMPANYNAME.MSC contains the configuration of multiple Remote Desktops sessions.  When I used to run it, after clicking on particular servers to login and logout and so on, upon shutdown it would prompt me to save settings.  I would say "no".  If I said "yes" it would remember which was the last server I had logged in to and then automatically log me in to that the next time it was launched.

    n.b. this is not the same as the individual Remote Desktop application, which does remember which server you used last, but it always prompts you with a dialog box when launched ... Remote Desktops does not do that.

    Whilst checking the "always ask for credentials" box for each configured server connection would stop it automatically logging in, it also means that I have to keep typing the passwords over and over, and I want to avoid that.

    Its no big deal; just a minor annoyance.  But I don't understand why Microsoft would go to the trouble of changing its default behaviour between Vista and Windows 7 and then not go to the trouble of providing us with a checkbox to tick or untick which says "Automatically connect to last server used".
    Wednesday, March 17, 2010 9:37 PM
  • May I suggest setting everything up with mstsc.exe, then doing a [Save As...] for each of the servers you regularly access.  Double clicking the .rdp files will take you directly to the server whose credentials are saved in the specific .rdp file.  Think of a .rdp file as a kind of a shortcut.

    Create a folder with the group of these "shortcuts" and double-click the appropriate one to make the connection you want.  These do not prompt, if you have stored the credentials.

    -Noel

     

    P.S., %windir%\system32\COMPANYNAME.msc (Remote Desktops) is not normally shipped with Windows.  A little research turned up this:

    http://technet.microsoft.com/en-us/library/cc773128(WS.10).aspx

    I mention this because it's possible that the fault lies within what may now be an outdated snapin.  Note that the compatibility listed on that page stops at Windows Server 2003.  A little more research turns up some people having trouble with Remote Desktops in Vista too.

    Do you know of a newer download than the one above?

    • Proposed as answer by Noel Carboni Friday, March 19, 2010 3:10 AM
    Friday, March 19, 2010 3:10 AM
  • Yes, I think you are on the money here.  This laptop did have Vista on it previously, then in-place upgrade to Windows 7.  I did have the remote administration tools for Windows Server 2003 installed on it.  After the upgrade to Windows 7, I had to download/install new tools for remote server management, so presumably Remote Desktops was not part of that new download and is a hangover from the earlier tools install.
    Monday, March 22, 2010 8:57 PM