locked
Outlook 2016 - Searching in "current folder" fails when current folder is in secondary mailbox RRS feed

  • Question

  • Hi, we are facing an issue with Outlook search after upgrading from Outlook 2013 to Outlook 2016. It affects users who are working with multiple mailboxes as separate accounts:

    If such a user opens a folder in the second (non-default) mailbox and searches for something in "Current Folder", he does not get any results:


    However, if the user changes the search scope from "Current Folder" to "All Mailboxes", he gets results from all folders in all mailboxes, including results in the current folder. So it seems that "Current Folder" actually means "Current Folder if it is in the primary mailbox".

    Not sure if related, but I also noticed that when searching for an expression with no matches, searching "Current Folder" returns "No matches found" while searching "All Mailboxes" returns "We couldn't find what you were looking for":

    This has worked fine in Outlook 2013. AFAIK Outlook 2016 uses server-based search (with Exchange 2016) which would explain the difference, but to me that seems like a bug.

    Tuesday, February 13, 2018 1:06 PM

Answers

  • Hi,

    What's the specific version number of Outlook you are using? You may hit a known issue. To temporarily work around this issue, try disabling Server Assisted Search via the following registry key:

    HKEY_CURRENT_USER\software\microsoft\office\16.0\outlook\search
    DWORD: DisableServerAssistedSearch
    Value Data: 1

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by svhelden Friday, February 16, 2018 9:04 AM
    Wednesday, February 14, 2018 6:05 AM

All replies

  • Hi,

    What's the specific version number of Outlook you are using? You may hit a known issue. To temporarily work around this issue, try disabling Server Assisted Search via the following registry key:

    HKEY_CURRENT_USER\software\microsoft\office\16.0\outlook\search
    DWORD: DisableServerAssistedSearch
    Value Data: 1

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    • Marked as answer by svhelden Friday, February 16, 2018 9:04 AM
    Wednesday, February 14, 2018 6:05 AM
  • Hi, thanks! It is Outlook 2016 32-bit with latest updates.

    That DWORD would revert to the Outlook 2013 behavior where search is based on the local Windows Search engine, right?

    Wednesday, February 14, 2018 6:23 AM
  • You're correct, it will disable the server side assisted search, and use the local Windows search engine. It will not affect your search behavior if everything is OK with your Windows Search.

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, February 14, 2018 6:26 AM
  • Ok, so that seems still a bug in Outlook 2016, but for the moment we can live with the workaround (to use local search). Thanks!
    Friday, February 16, 2018 9:05 AM
  • You're welcome :-)

    Regards,
    Steve Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Sunday, February 18, 2018 7:12 AM