locked
Windows 2008 - Must disable UAC RRS feed

  • General discussion

  •  

    I answered my own problem in another post, but to anyone that is having repeated problems installing Exchange 2007 SP1 on Windows Server 2008 because it doesn't have permission to write to its own setup logs there is a simple answer: Disable UAC and you will have no more problems.  This one had me stumped for a while.

     

    *Note - to disable UAC, it is the same as in Vista: Go to Control Panel | Users, and it is an option in there.

    Tuesday, February 26, 2008 5:35 AM

All replies

  • You can also run MSCONFIG and go to the Tools tab.  Its at the bottom.  Just click an run.

    Thursday, February 28, 2008 5:28 AM
  • Is there a CLI to do this?
    Wednesday, July 22, 2009 4:27 PM
  • UAC is a security feature that should be turned on.
    Run the setup program with "run as admiinistrator"


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    Thursday, July 23, 2009 9:21 AM
  • If you select "DISABLE UAC" in MSCONFIG, it will show you the CLI in the Bottom .....
    Friday, July 24, 2009 10:05 AM
  • UAC is a security feature that should be turned on .
    Run the setup program with "run as admiinistrator"


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com

    This is not always going to be the answer.  Not everyone's needs for features and security are the same, hence the ability exists to turn it off.

    We have one 2008 server that we really struggled with, trying to fit all the functionality that we needed into the new UAC model/feature.  Ultimately we had to disable UAC.

    Thankfully we all get to make these choices and of course live with any downsides that may exist (either way).
    Friday, July 31, 2009 11:14 PM
  • That is true that sometimes applications dont work ok with UAC, but Exchange is one application that do work ok with UAC turned on.


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    Sunday, August 2, 2009 6:28 AM
  • Using administrator account is not a solution for a web application.
    Tuesday, September 7, 2010 7:57 AM
  • Ditto SQL Server Reporting Services.  We are not able to utlize Report Manager role settings with groups when UAC is enabled even the individual users in the group are able to be view reports when assigned those priviledges.  I was hoping Windows Server 2008 did not utilize UAC.  I am disappointed that it does.
    Edward R. Joell MCSD MCDBA
    Tuesday, June 28, 2011 2:15 PM
  • Same applies with WMI. UAC screws that up completely!
    Wednesday, June 29, 2011 7:23 AM
  • I agree with rhuston, even the simple act of creating files when logged in as an administrator blocked.  There are 2 work around, disable UAC or give "users" permissions to write since the administrator account is treated as a "user".  Oddly enough, disabling UAC is the more secure solution.
    Tuesday, October 25, 2011 5:56 PM
  • I am moving lots of directories from 2003 to 2008. Getting permissions cleaned up and set correctly with UAC on is a pain in the arse.

    "There are 2 work around, disable UAC or give "users" permissions to write since the administrator account is treated as a "user".  Oddly enough, disabling UAC is the more secure solution."

    Well said.

    Monday, November 7, 2011 7:31 PM
  • What a ridiculous response. As everyone as noted, UAC _HAS_ to be disabled. It is a security feature, but it is a BROKEN security feature. To work around the failure, it has to be disabled.

    Please don't answer with responses like this if you have no idea about the situation as it doesn't help anyone. Real-world situations require real-word answers, not "theory".

     

     

     

    Friday, January 27, 2012 3:07 PM
  • See http://support.microsoft.com/kb/2526083 , where Microsoft suggests turning off UAC on servers under certain circumstances -- basically where all you will do on that server console is admin tasks, not web browsing, etc.
    Wednesday, October 3, 2012 3:36 PM
  • I've just had an entirely wondrous problem... couldn't do anything (no UAC prompting) when NIC was disconnected/unplugged... as if networking was a UAC requirement on a SBS server with no secondary domain controllers...  ENTIRELY contrary to concept... 

    Moment I plug in NIC to disabled NIC on same computer... 10 different UAC confirmations finally popped up...

    no wonder every SBS in existence takes 30 minutes to shutdown and another 15 minutes starting up "applying computer settings"... networking should not be a requirement and I don't know who or what or where SBS is trying to communicate with when there shouldn't be a network.

    Stupid standalone SBS domain controllers require networking and can't actually talk to themselves first.

    I going to start disabling UAC on every server I touch.




    • Edited by tymes Tuesday, July 23, 2013 4:58 AM clairity
    Tuesday, July 23, 2013 4:43 AM